media-tv/kodi: Set KODI_HOME when running tests
authorCraig Andrews <candrews@gentoo.org>
Mon, 18 May 2020 16:11:08 +0000 (12:11 -0400)
committerCraig Andrews <candrews@gentoo.org>
Mon, 18 May 2020 16:11:43 +0000 (12:11 -0400)
See https://github.com/xbmc/xbmc/issues/17860#issuecomment-630120213

Bug: https://bugs.gentoo.org/722578
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-tv/kodi/kodi-18.6.ebuild
media-tv/kodi/kodi-9999.ebuild

index 415eac36df3a377bd841905cf8036d61a06b0b85..25f6abdbcdfa803925288a2ff79c3ee8e7551d7d 100644 (file)
@@ -301,7 +301,8 @@ src_compile() {
 }
 
 src_test() {
-       cmake_build check
+       # see https://github.com/xbmc/xbmc/issues/17860#issuecomment-630120213
+       KODI_HOME="${BUILD_DIR}" cmake_build check
 }
 
 src_install() {
index 9bee9585390c52d2b1289fd242bee7f712dcc3f8..11b1d97b1ed3b406a4336eb71ff7f69cccbaa7b1 100644 (file)
@@ -298,7 +298,8 @@ src_compile() {
 }
 
 src_test() {
-       cmake_build check
+       # see https://github.com/xbmc/xbmc/issues/17860#issuecomment-630120213
+       KODI_HOME="${BUILD_DIR}" cmake_build check
 }
 
 src_install() {