Version bump, bug #137945. Thanks to Jakub Zawadzki
authorKarol Wojtaszek <sekretarz@gentoo.org>
Mon, 9 Oct 2006 19:50:13 +0000 (19:50 +0000)
committerKarol Wojtaszek <sekretarz@gentoo.org>
Mon, 9 Oct 2006 19:50:13 +0000 (19:50 +0000)
Package-Manager: portage-2.1.2_pre2-r5

net-libs/libgadu/ChangeLog
net-libs/libgadu/files/digest-libgadu-1.7.0 [new file with mode: 0644]
net-libs/libgadu/files/digest-libgadu-1.7.0_pre20050719 [new file with mode: 0644]
net-libs/libgadu/libgadu-1.7.0.ebuild [new file with mode: 0644]
net-libs/libgadu/libgadu-1.7.0_pre20050719.ebuild [new file with mode: 0644]

index a3eec6640369570f76181647d637398fad013880..4b608c3c82eb34700f73b0d335754201a3e04683 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for net-libs/libgadu
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.13 2006/09/08 19:29:57 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.14 2006/10/09 19:50:13 sekretarz Exp $
+
+*libgadu-1.7.0 (09 Oct 2006)
+*libgadu-1.7.0_pre20050719 (09 Oct 2006)
+
+  09 Oct 2006; Karol Wojtaszek <sekretarz@gentoo.org>
+  +libgadu-1.7.0_pre20050719.ebuild, +libgadu-1.7.0.ebuild,
+  -libgadu-20040820.ebuild, -libgadu-20041230.ebuild,
+  -libgadu-20050719.ebuild:
+  Version bump, bug #137945. Thanks to Jakub Zawadzki
 
   08 Sep 2006; Markus Rothe <corsair@gentoo.org> libgadu-20050719.ebuild:
   Added ~ppc64; bug #146851
diff --git a/net-libs/libgadu/files/digest-libgadu-1.7.0 b/net-libs/libgadu/files/digest-libgadu-1.7.0
new file mode 100644 (file)
index 0000000..e8aa52f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 152180afbbad584017592a3021aac97a libgadu-1.7.0.tar.gz 382784
+RMD160 91cdf5ebfd0e1cfe3a8af3028374827ac39294f3 libgadu-1.7.0.tar.gz 382784
+SHA256 13b0c4c1471f40022db3fd7d141d5d0b42dd67f0a9ca82db877c39b60e14071a libgadu-1.7.0.tar.gz 382784
diff --git a/net-libs/libgadu/files/digest-libgadu-1.7.0_pre20050719 b/net-libs/libgadu/files/digest-libgadu-1.7.0_pre20050719
new file mode 100644 (file)
index 0000000..935618c
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 7bae3fef17b7a7b7f27c8d901eef31d4 libgadu-20050719.tar.gz 211435
+RMD160 1b3b6855df3a161a9a3b7a2c4895aa1d78aa3fd4 libgadu-20050719.tar.gz 211435
+SHA256 68dd56cb502a3265581f80c4832bb7e5fa1bf3212af6ff09bb2f34ce83a8f74c libgadu-20050719.tar.gz 211435
diff --git a/net-libs/libgadu/libgadu-1.7.0.ebuild b/net-libs/libgadu/libgadu-1.7.0.ebuild
new file mode 100644 (file)
index 0000000..d297317
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/libgadu-1.7.0.ebuild,v 1.1 2006/10/09 19:50:13 sekretarz Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
+HOMEPAGE="http://toxygen.net/libgadu/"
+SRC_URI="http://toxygen.net/libgadu/files/libgadu-1.7.0.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="ssl threads"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6m )"
+
+src_compile() {
+       econf \
+           --enable-shared \
+           `use_with threads pthread` \
+           `use_with ssl openssl` \
+            || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+src_install() {
+       einstall || die
+}
diff --git a/net-libs/libgadu/libgadu-1.7.0_pre20050719.ebuild b/net-libs/libgadu/libgadu-1.7.0_pre20050719.ebuild
new file mode 100644 (file)
index 0000000..4d6a219
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/libgadu-1.7.0_pre20050719.ebuild,v 1.1 2006/10/09 19:50:13 sekretarz Exp $
+
+inherit eutils libtool
+
+# This ebuild will be removed soon
+VER="20050719"
+
+DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
+HOMEPAGE="http://dev.null.pl/ekg"
+SRC_URI="http://dev.gentoo.org/~sekretarz/distfiles/${PN}-${VER}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ~ppc64 ~sparc x86"
+
+IUSE="ssl threads"
+
+S=${WORKDIR}/${PN}-${VER}
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6m )"
+
+src_compile() {
+       aclocal -I m4
+       autoheader
+       autoconf
+       elibtoolize
+       econf \
+           --enable-shared \
+           `use_with threads pthread` \
+           `use_with ssl openssl` \
+            || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+src_install() {
+       einstall || die
+}