dev-ros/rosbridge_server: remove old and drop py27 support.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 11 Dec 2019 17:11:28 +0000 (18:11 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 10:42:05 +0000 (11:42 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/rosbridge_server/Manifest
dev-ros/rosbridge_server/files/backports-ssl.patch [deleted file]
dev-ros/rosbridge_server/files/tornado.patch [deleted file]
dev-ros/rosbridge_server/rosbridge_server-0.10.1.ebuild [deleted file]
dev-ros/rosbridge_server/rosbridge_server-0.11.1.ebuild
dev-ros/rosbridge_server/rosbridge_server-0.8.6.ebuild [deleted file]
dev-ros/rosbridge_server/rosbridge_server-0.9.0.ebuild [deleted file]
dev-ros/rosbridge_server/rosbridge_server-9999.ebuild

index 93133e08b7294f2dee0b94d4dfacc9167b633d51..b60679b4626ef7a0719b2c5ff3e125e2a3e4fb8e 100644 (file)
@@ -1,4 +1 @@
-DIST rosbridge_suite-0.10.1.tar.gz 98010 BLAKE2B d634840a68081e7afaba77cff2b0f435392aa061ef6a4d4e75feccaa26811df92e0cd3c1b83973bd7eab534e66a5d5df880428d82fdd7cf20c7997a3427fdcf5 SHA512 455950eb5aebdccd6f173f2b7d1ea0bdf74421172895ab13e3af698a79e49964cb53354f90c396aad596818ecbb36385a3e1c9c373feb3a15aeff13d9e703443
 DIST rosbridge_suite-0.11.1.tar.gz 100994 BLAKE2B b6b21e1f8444b969d94ae1c86c70f242075c1494359df062179789920b3c03aa6ed44dd273c301098ed43f6084c656018349022158ec4b9b4672f20262952c05 SHA512 dd89d43b20589ac436cba673b3ee4f229eb14d47aabbe8352e04d6a2691b6f9e156315788178fbe345fa489fa84f86c626647b09ff3632562eb023bca688451c
-DIST rosbridge_suite-0.8.6.tar.gz 378267 BLAKE2B b5e72b7897feef66aa05603bcff00ba213844f700f56be97a7110f33a77e3aa848ca0c583d5509ee205dc01bf001181b1887e20ee89d8348bc5eb43fd5a829b0 SHA512 e935c20466a13cbcf00051a4f32bc981806244aecf314e09e9e0ca9e0e873ab098b14b5ca5839bf14f2d3dfb823ecc62bb4e26027d4d0ff3f52bf0385011fbf3
-DIST rosbridge_suite-0.9.0.tar.gz 89409 BLAKE2B e48f36b71d8c5bcbd1ede0a87015b231d45194f3410b4cfcc38d39089477418b1f40afb28d8df7beba2e5e99b4aafde53bbc3f9bf371f0434099d7730c6393ee SHA512 4d7a6c0c33da9bf42ff24a0add81cad5fec707ef7149bf929bd2aac92ea2fe6f42da21bd5349dadee05cacb69d7efdb7adb0c01fc01c8251e0503cb488a73364
diff --git a/dev-ros/rosbridge_server/files/backports-ssl.patch b/dev-ros/rosbridge_server/files/backports-ssl.patch
deleted file mode 100644 (file)
index b8fc226..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: rosbridge_server/setup.py
-===================================================================
---- rosbridge_server.orig/setup.py
-+++ rosbridge_server/setup.py
-@@ -11,8 +11,6 @@ from catkin_pkg.python_setup import gene
- d = generate_distutils_setup(
-     packages=[
-         'rosbridge_server',
--        'backports',
--        'backports.ssl_match_hostname',
-         'tornado',
-         'tornado.platform'
-     ],
diff --git a/dev-ros/rosbridge_server/files/tornado.patch b/dev-ros/rosbridge_server/files/tornado.patch
deleted file mode 100644 (file)
index ae23913..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-Index: rosbridge_server/setup.py
-===================================================================
---- rosbridge_server.orig/setup.py
-+++ rosbridge_server/setup.py
-@@ -10,85 +10,9 @@ from catkin_pkg.python_setup import gene
- d = generate_distutils_setup(
-     packages=[
--        'rosbridge_server',
--        'tornado',
--        'tornado.platform'
-+        'rosbridge_server'
-     ],
-     package_dir={'': 'src'}
- )
--# The following code is copied from
--# https://github.com/mongodb/mongo-python-driver/blob/master/setup.py
--# to support installing without the extension on platforms where
--# no compiler is available.
--from distutils.command.build_ext import build_ext
--
--class custom_build_ext(build_ext):
--    """Allow C extension building to fail.
--
--    The C extension speeds up websocket masking, but is not essential.
--    """
--
--    warning_message = """
--********************************************************************
--WARNING: %s could not
--be compiled. No C extensions are essential for Tornado to run,
--although they do result in significant speed improvements for
--websockets.
--%s
--
--Here are some hints for popular operating systems:
--
--If you are seeing this message on Linux you probably need to
--install GCC and/or the Python development package for your
--version of Python.
--
--Debian and Ubuntu users should issue the following command:
--
--    $ sudo apt-get install build-essential python-dev
--
--RedHat, CentOS, and Fedora users should issue the following command:
--
--    $ sudo yum install gcc python-devel
--********************************************************************
--"""
--
--    def run(self):
--        try:
--            build_ext.run(self)
--        except Exception:
--            e = sys.exc_info()[1]
--            sys.stdout.write('%s\n' % str(e))
--            warnings.warn(self.warning_message % ("Extension modules",
--                                                  "There was an issue with "
--                                                  "your platform configuration"
--                                                  " - see above."))
--
--    def build_extension(self, ext):
--        name = ext.name
--        try:
--            build_ext.build_extension(self, ext)
--        except Exception:
--            e = sys.exc_info()[1]
--            sys.stdout.write('%s\n' % str(e))
--            warnings.warn(self.warning_message % ("The %s extension "
--                                                  "module" % (name,),
--                                                  "The output above "
--                                                  "this warning shows how "
--                                                  "the compilation "
--                                                  "failed."))
--
--if (platform.python_implementation() == 'CPython' and
--    os.environ.get('TORNADO_EXTENSION') != '0'):
--    # This extension builds and works on pypy as well, although pypy's jit
--    # produces equivalent performance.
--    d['ext_modules'] = [
--        Extension('tornado.speedups', sources=['src/tornado/speedups.c']),
--    ]
--
--    if os.environ.get('TORNADO_EXTENSION') != '1':
--        # Unless the user has specified that the extension is mandatory,
--        # fall back to the pure-python implementation on any build failure.
--        d['cmdclass'] = {'build_ext': custom_build_ext}
--
- setup(**d)
diff --git a/dev-ros/rosbridge_server/rosbridge_server-0.10.1.ebuild b/dev-ros/rosbridge_server/rosbridge_server-0.10.1.ebuild
deleted file mode 100644 (file)
index 9fe85a4..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
-KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="A WebSocket interface to rosbridge"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/rosapi[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
-       dev-ros/rospy[${PYTHON_USEDEP}]
-       dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
-       dev-ros/rosauth[${PYTHON_USEDEP}]
-       dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
-       www-servers/tornado[${PYTHON_USEDEP}]
-       "
-DEPEND="${RDEPEND}"
index 703a455899be42f595c972c1a4ec389baed14ae0..cf540ab83cadc9e418d3bcb9b7f83e3e811cca9a 100644 (file)
@@ -19,7 +19,6 @@ RDEPEND="
        dev-ros/rospy[${PYTHON_USEDEP}]
        dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
        dev-ros/rosauth[${PYTHON_USEDEP}]
-       dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
        www-servers/tornado[${PYTHON_USEDEP}]
        "
 DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosbridge_server/rosbridge_server-0.8.6.ebuild b/dev-ros/rosbridge_server/rosbridge_server-0.8.6.ebuild
deleted file mode 100644 (file)
index 775590d..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
-KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="A WebSocket interface to rosbridge"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/rosapi[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
-       dev-ros/rospy[${PYTHON_USEDEP}]
-       dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
-       dev-ros/rosauth[${PYTHON_USEDEP}]
-       dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
-       www-servers/tornado[${PYTHON_USEDEP}]
-       "
-DEPEND="${RDEPEND}"
-PATCHES=(
-       "${FILESDIR}/backports-ssl.patch"
-       "${FILESDIR}/tornado.patch"
-)
diff --git a/dev-ros/rosbridge_server/rosbridge_server-0.9.0.ebuild b/dev-ros/rosbridge_server/rosbridge_server-0.9.0.ebuild
deleted file mode 100644 (file)
index 1ea9a84..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
-KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="A WebSocket interface to rosbridge"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       dev-ros/rosapi[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
-       dev-ros/rospy[${PYTHON_USEDEP}]
-       dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
-       dev-ros/rosauth[${PYTHON_USEDEP}]
-       dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
-       www-servers/tornado[${PYTHON_USEDEP}]
-       "
-DEPEND="${RDEPEND}"
index 1ea9a841c8fd18f4bcf305d08127cdee6f3d394c..cf540ab83cadc9e418d3bcb9b7f83e3e811cca9a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -19,7 +19,6 @@ RDEPEND="
        dev-ros/rospy[${PYTHON_USEDEP}]
        dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
        dev-ros/rosauth[${PYTHON_USEDEP}]
-       dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
        www-servers/tornado[${PYTHON_USEDEP}]
        "
 DEPEND="${RDEPEND}"