media-libs/mesa: Update deps for slotted LLVM
authorMichał Górny <mgorny@gentoo.org>
Sat, 4 Feb 2017 12:47:34 +0000 (13:47 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 15 Feb 2017 12:47:24 +0000 (13:47 +0100)
Support slotted LLVM versions correctly. Allow any version for 9999,
limit to <5 for 17.0.0_rc2 as current git does not work anymore.
For the older 13.0.4 branch, just force slot :0 since it does not
support 4.0 (the oldest slotted version).

media-libs/mesa/mesa-13.0.4.ebuild
media-libs/mesa/mesa-17.0.0.ebuild
media-libs/mesa/mesa-9999.ebuild

index 9948e240507c7409edcff5b8cca876e00ce88b27..84081c5be9e34a212936fe5846491eaaef23f496 100644 (file)
@@ -99,9 +99,9 @@ RDEPEND="
        llvm? (
                video_cards_radeonsi? (
                        virtual/libelf:0=[${MULTILIB_USEDEP}]
-                       vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
+                       vulkan? ( >=sys-devel/llvm-3.9.0:0=[${MULTILIB_USEDEP}] )
                )
-               >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
+               >=sys-devel/llvm-3.6.0:0=[${MULTILIB_USEDEP}]
        )
        nettle? ( dev-libs/nettle:=[${MULTILIB_USEDEP}] )
        !nettle? (
@@ -151,8 +151,8 @@ DEPEND="${RDEPEND}
                ) )
        )
        opencl? (
-                               >=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]
-                               >=sys-devel/clang-3.4.2:=[${MULTILIB_USEDEP}]
+                               >=sys-devel/llvm-3.4.2:0=[${MULTILIB_USEDEP}]
+                               >=sys-devel/clang-3.4.2:0=[${MULTILIB_USEDEP}]
                                >=sys-devel/gcc-4.6
        )
        sys-devel/gettext
index 11b03e23a36e256bf5d2bafafb06fad460a990ab..b35f0bc5ef275a34868acdafb52b4fc531ce421b 100644 (file)
@@ -13,7 +13,7 @@ fi
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit autotools multilib-minimal python-any-r1 pax-utils ${GIT_ECLASS}
+inherit autotools llvm multilib-minimal python-any-r1 pax-utils ${GIT_ECLASS}
 
 OPENGL_DIR="xorg-x11"
 
@@ -99,9 +99,16 @@ RDEPEND="
        llvm? (
                video_cards_radeonsi? (
                        virtual/libelf:0=[${MULTILIB_USEDEP}]
-                       vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
+                       vulkan? (
+                               || (
+                                       sys-devel/llvm:4
+                                       >=sys-devel/llvm-3.9.0:0[${MULTILIB_USEDEP}] ) )
                )
-               >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
+               || (
+                       sys-devel/llvm:4
+                       >=sys-devel/llvm-3.6.0:0[${MULTILIB_USEDEP}]
+               )
+               <sys-devel/llvm-5:=
        )
        opencl? (
                                app-eselect/eselect-opencl
@@ -143,9 +150,15 @@ DEPEND="${RDEPEND}
                ) )
        )
        opencl? (
-                               >=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]
-                               >=sys-devel/clang-3.4.2:=[${MULTILIB_USEDEP}]
-                               >=sys-devel/gcc-4.6
+               || (
+                       sys-devel/llvm:4
+                       >=sys-devel/llvm-3.6.0:0[${MULTILIB_USEDEP}]
+               )
+               || (
+                       sys-devel/clang:4
+                       >=sys-devel/clang-3.6.0:0[${MULTILIB_USEDEP}]
+               )
+               >=sys-devel/gcc-4.6
        )
        sys-devel/gettext
        virtual/pkgconfig
@@ -188,6 +201,7 @@ pkg_setup() {
                ewarn "detected! This can cause problems. For details, see bug 459306."
        fi
 
+       LLVM_MAX_SLOT=4 llvm_pkg_setup
        python-any-r1_pkg_setup
 }
 
index 11b03e23a36e256bf5d2bafafb06fad460a990ab..fe87f66a7bdf3895531cbecf209dd6b2831b0736 100644 (file)
@@ -13,7 +13,7 @@ fi
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit autotools multilib-minimal python-any-r1 pax-utils ${GIT_ECLASS}
+inherit autotools llvm multilib-minimal python-any-r1 pax-utils ${GIT_ECLASS}
 
 OPENGL_DIR="xorg-x11"
 
@@ -143,8 +143,8 @@ DEPEND="${RDEPEND}
                ) )
        )
        opencl? (
-                               >=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]
-                               >=sys-devel/clang-3.4.2:=[${MULTILIB_USEDEP}]
+                               >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
+                               >=sys-devel/clang-3.6.0:=[${MULTILIB_USEDEP}]
                                >=sys-devel/gcc-4.6
        )
        sys-devel/gettext
@@ -188,6 +188,7 @@ pkg_setup() {
                ewarn "detected! This can cause problems. For details, see bug 459306."
        fi
 
+       llvm_pkg_setup
        python-any-r1_pkg_setup
 }