dev-php/PEAR-Image_GraphViz: Version bump direct to stable
authorBrian Evans <grknight@gentoo.org>
Mon, 19 Feb 2018 16:10:50 +0000 (11:10 -0500)
committerBrian Evans <grknight@gentoo.org>
Mon, 19 Feb 2018 16:10:50 +0000 (11:10 -0500)
Old version is very broken:
No tests enabled
Missing dependencies
Will not work on PHP 7

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-php/PEAR-Image_GraphViz/Manifest
dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0-r1.ebuild [deleted file]
dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild [new file with mode: 0644]
dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch [new file with mode: 0644]

index 3ac3b7d837756819a5214a29e0f8b5b05a6cd632..4097cd4621197132eb2c90ea85524055c27af7ae 100644 (file)
@@ -1 +1 @@
-DIST Image_GraphViz-1.3.0.tgz 16706 BLAKE2B 7485bd41758d634fd6fa925ad4fa877c8f1da295e3cde3c8093676152d28e0c93bbbcb72c269087c59fd20e267de0e0d3a7e93fddab6a0e4a7ead5eb19306c74 SHA512 08113e40dd78638ffc0f142699c472075df65c08a0a42d928f91bc0c0a1fbe0f97700dac27de24d98f284d444097d576af3f5c8f798e3e8c1dd58850df6b5b76
+DIST Image_GraphViz-1.3.0_p20151104.tar.gz 18109 BLAKE2B 9a8c269a7f4eff787a67c84770c296d3e032a038cae04b888ea5ae26525b24a764ad01d6300d7e7a4c3cf78acb4e077b1f9091cced4ef57031f6ce3aaef2a8e3 SHA512 69e9117cff950a45d8f3cfd5759be8194f477b55c09ceb990707f3ad2de2500a570fa124b73b2c81cdd6ce20b6c11fc0532a0087a515cf3c7c9a5a8ed7b1c58f
diff --git a/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0-r1.ebuild b/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0-r1.ebuild
deleted file mode 100644 (file)
index e445da5..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit php-pear-r1
-
-DESCRIPTION="PHP interface to AT&T's GraphViz tools"
-LICENSE="PHP-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ~ia64 ~sparc x86"
-IUSE=""
diff --git a/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild b/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
new file mode 100644 (file)
index 0000000..6f78060
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="PHP interface to AT&T's GraphViz tools"
+SRC_URI="https://github.com/pear/Image_GraphViz/archive/3f8a01ae0597ca9d1d08a6e442cb0b153358fc0d.tar.gz -> ${PEAR_P}.tar.gz"
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~sparc x86"
+IUSE="test"
+RDEPEND="media-gfx/graphviz"
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+PATCHES=( "${FILESDIR}/Image_GraphViz-1.3.0-constructor.patch" )
+S="${WORKDIR}/${PEAR_P}"
+
+src_prepare() {
+       mv "${S}/package.xml" "${WORKDIR}" || die
+       default
+}
+
+src_test() {
+       peardev run-tests tests || die
+}
diff --git a/dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch b/dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch
new file mode 100644 (file)
index 0000000..da7dfd4
--- /dev/null
@@ -0,0 +1,55 @@
+From 794fdf40ad944225854845a0ff32a5c56fb249d9 Mon Sep 17 00:00:00 2001
+From: Seb35 <seb35@seb35.fr>
+Date: Sun, 6 Nov 2016 22:42:46 +0100
+Subject: [PATCH] Added __construct constructor
+
+This removes deprecation warnings due to old constructor
+(method with the class name). Keep the old-style constructor
+for compatibility (like in the PEAR main class).
+---
+ Image/GraphViz.php | 25 ++++++++++++++++++++++++-
+ 1 file changed, 24 insertions(+), 1 deletion(-)
+
+diff --git a/Image/GraphViz.php b/Image/GraphViz.php
+index ee84ff2..92842da 100644
+--- a/Image/GraphViz.php
++++ b/Image/GraphViz.php
+@@ -181,7 +181,7 @@ class Image_GraphViz
+      *
+      * @access public
+      */
+-    function Image_GraphViz($directed = true, $attributes = array(),
++    function __construct($directed = true, $attributes = array(),
+                             $name = 'G', $strict = true, $returnError = false)
+     {
+         $this->setDirected($directed);
+@@ -192,6 +192,29 @@ function Image_GraphViz($directed = true, $attributes = array(),
+         $this->_returnFalseOnError = !$returnError;
+     }
++    /**
++     * Compatibility constructor.
++     *
++     * @param boolean $directed    Directed (TRUE) or undirected (FALSE) graph.
++     *                             Note: You MUST pass a boolean, and not just
++     *                             an  expression that evaluates to TRUE or
++     *                             FALSE (i.e. NULL, empty string, 0 will NOT
++     *                             work)
++     * @param array   $attributes  Attributes of the graph
++     * @param string  $name        Name of the Graph
++     * @param boolean $strict      Whether to collapse multiple edges between
++     *                             same nodes
++     * @param boolean $returnError Set to TRUE to return PEAR_Error instances
++     *                             on failures instead of FALSE
++     *
++     * @access public
++     */
++    function Image_GraphViz($directed = true, $attributes = array(),
++                            $name = 'G', $strict = true, $returnError = false)
++    {
++        self::__construct($directed, $attributes, $name, $strinct, $returnError);
++    }
++
+     /**
+      * Outputs image of the graph in a given format
+      *