dev-libs/botan: cleanup
authorAlon Bar-Lev <alonbl@gentoo.org>
Tue, 14 Mar 2017 23:42:05 +0000 (01:42 +0200)
committerAlon Bar-Lev <alonbl@gentoo.org>
Wed, 15 Mar 2017 06:27:02 +0000 (08:27 +0200)
Bug: 611498

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-libs/botan/Manifest
dev-libs/botan/botan-1.10.14.ebuild [deleted file]
dev-libs/botan/botan-1.10.15.ebuild [deleted file]
dev-libs/botan/files/botan-1.10.14-build.patch [deleted file]

index 1b0cc50b4caac42f1e4f92f9226590a4840db7ae..492902f842f56d595dcd37bb26e68224783a9b9b 100644 (file)
@@ -1,3 +1,2 @@
-DIST Botan-1.10.14.tgz 2710757 SHA256 10ed0b394db165733ac9557d8656356b7e9744d38c61c2b9c44cba6d84ff4c1c SHA512 ae524653a99b02d6d8d7bb2b88a446c066fe1044d8fd2708ea2a4cd5aafbe2b0d165d2ce1730669a4df18013cf5b6540bb5944bafea512b4957e3417de512e95 WHIRLPOOL 51aa1d68757ad515f65c255c585be8050efed085800340d43fa068b48647ef8c50fc9e284ac16d0cef3d874f5fa44f143210dcc004561807e1d1b307d89cff9d
 DIST Botan-1.10.15.tgz 2711022 SHA256 c0cc8ffd470fda4b257c3ef9faf5cf93751f4c283dfba878148acafedfab70fe SHA512 c3b93f44ad0de9758af11557833ee570aa0724c8b57c9a576b56ab439a7819e0f71a10857ad367b486716164dd4ff551cab2036ecbbbedd75db4b8dc93416bc8 WHIRLPOOL 834cad8b38787581d8d967b2fa6ffb6164e2bf8a124d993733a7d55202439ec543c18cb6cb03721c0e8eb67cbe2a486b8199b3b8784645e0033be298f36640b9
 DIST Botan-2.0.1.tgz 4995413 SHA256 a138ed316d11450a8405451b9c9664b8e640a9b7ad84d3f3ad34e8071f364e0b SHA512 c5062ce92a6e6e333b4e6af095ed54d0c4ffacefc6ac87ec651dd1e0937793c9956b7c9c0d3acf49f059505526584168364e01c55ab72c953ad255e8396aed35 WHIRLPOOL 36cec762b05b761d77fc0421379e7c78172c67d1d8c9da4349df34f68d7d1a4fd5cca394ba4bd7c2e1a13a218a6a349b2216bfd7868e93549e37e5cf7ddc7dc1
diff --git a/dev-libs/botan/botan-1.10.14.ebuild b/dev-libs/botan/botan-1.10.14.ebuild
deleted file mode 100644 (file)
index 6bb0c29..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit eutils multilib python-r1 toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="http://botan.randombit.net/"
-SRC_URI="http://botan.randombit.net/releases/${MY_P}.tgz"
-
-KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 sparc x86 ~ppc-macos"
-SLOT="0"
-LICENSE="BSD"
-IUSE="bindist doc python bzip2 gmp ssl static-libs threads zlib"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
-       zlib? ( >=sys-libs/zlib-1.2.3 )
-       python? ( ${PYTHON_DEPS} >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}] )
-       gmp? ( >=dev-libs/gmp-4.2.2:* )
-       ssl? ( >=dev-libs/openssl-0.9.8g:*[bindist=] )"
-DEPEND="${RDEPEND}
-       doc? ( dev-python/sphinx )"
-
-PATCHES=(
-       "${FILESDIR}/${P}-build.patch"
-)
-
-src_prepare() {
-       default
-
-       sed -e "s/-Wl,-soname,\$@ //" -i src/build-data/makefile/python.in || die "sed failed"
-       sed \
-               -e "/DOCDIR/d" \
-               -e "/^install:/s/ docs//" \
-               -i src/build-data/makefile/unix_shr.in || die "sed failed"
-
-       # Fix ImportError with Python 3.
-       sed -e "s/_botan/.&/" -i src/wrap/python/__init__.py || die "sed failed"
-
-       use python && python_copy_sources
-}
-
-src_configure() {
-       local disable_modules="proc_walk,unix_procs"
-       use threads || disable_modules+=",pthreads"
-       use bindist && disable_modules+=",ecdsa"
-       elog "Disabling modules: ${disable_modules}"
-
-       # Enable v9 instructions for sparc64
-       if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
-               CHOSTARCH="sparc32-v9"
-       else
-               CHOSTARCH="${CHOST%%-*}"
-       fi
-
-       local myos=
-       case ${CHOST} in
-               *-darwin*)   myos=darwin ;;
-               *)           myos=linux  ;;
-       esac
-
-       # foobared buildsystem, --prefix translates into DESTDIR, see also make
-       # install in src_install, we need the correct live-system prefix here on
-       # Darwin for a shared lib with correct install_name
-       ./configure.py \
-               --prefix="${EPREFIX}/usr" \
-               --libdir=$(get_libdir) \
-               --docdir=share/doc \
-               --cc=gcc \
-               --os=${myos} \
-               --cpu=${CHOSTARCH} \
-               --with-endian="$(tc-endian)" \
-               --without-sphinx \
-               --with-tr1=system \
-               $(use_with bzip2) \
-               $(use_with gmp gnump) \
-               $(use_with python boost-python) \
-               $(use_with ssl openssl) \
-               $(use_with zlib) \
-               --disable-modules=${disable_modules} \
-               || die "configure.py failed"
-}
-
-src_compile() {
-       emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT=""
-
-       if use python; then
-               building() {
-                       rm -fr build/python
-                       ln -s "${BUILD_DIR}" build/python
-                       cp Makefile.python build/python
-                       sed -i \
-                               -e "s/-lboost_python/-lboost_python-$(echo ${EPYTHON} | sed 's/python//')/" \
-                               build/python/Makefile.python
-                       emake -f build/python/Makefile.python \
-                               CXX="$(tc-getCXX)" \
-                               CFLAGS="${CXXFLAGS}" \
-                               LDFLAGS="${LDFLAGS}" \
-                               PYTHON_ROOT="/usr/$(get_libdir)" \
-                               PYTHON_INC="-I$(python_get_includedir)"
-               }
-               python_foreach_impl building
-       fi
-
-       if use doc; then
-               einfo "Generation of documentation"
-               sphinx-build doc doc_output
-       fi
-}
-
-src_test() {
-       chmod -R ugo+rX "${S}"
-       emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check
-       LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
-}
-
-src_install() {
-       emake DESTDIR="${ED}usr" install
-
-       if ! use static-libs; then
-               rm "${ED}usr/$(get_libdir)/libbotan"*.a || die 'remove of static libs failed'
-       fi
-
-       # Add compatibility symlinks.
-       [[ -e "${ED}usr/bin/botan-config" ]] && die "Compatibility code no longer needed"
-       [[ -e "${ED}usr/$(get_libdir)/pkgconfig/botan.pc" ]] && die "Compatibility code no longer needed"
-       dosym botan-config-1.10 /usr/bin/botan-config
-       dosym botan-1.10.pc /usr/$(get_libdir)/pkgconfig/botan.pc
-
-       if use python; then
-               installation() {
-                       rm -fr build/python
-                       ln -s "${BUILD_DIR}" build/python
-                       emake -f Makefile.python \
-                               PYTHON_SITE_PACKAGE_DIR="${ED}$(python_get_sitedir)" \
-                               install
-               }
-               python_foreach_impl installation
-       fi
-
-       if use doc; then
-               pushd doc_output > /dev/null
-               insinto /usr/share/doc/${PF}/html
-               doins -r [a-z]* _static
-               popd > /dev/null
-       fi
-}
diff --git a/dev-libs/botan/botan-1.10.15.ebuild b/dev-libs/botan/botan-1.10.15.ebuild
deleted file mode 100644 (file)
index 012154b..0000000
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit eutils multilib python-r1 toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="http://botan.randombit.net/"
-SRC_URI="http://botan.randombit.net/releases/${MY_P}.tgz"
-
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
-SLOT="0"
-LICENSE="BSD"
-IUSE="bindist doc python bzip2 gmp ssl static-libs threads zlib"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
-       zlib? ( >=sys-libs/zlib-1.2.3 )
-       python? ( ${PYTHON_DEPS} >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}] )
-       gmp? ( >=dev-libs/gmp-4.2.2:* )
-       ssl? ( >=dev-libs/openssl-0.9.8g:*[bindist=] )"
-DEPEND="${RDEPEND}
-       doc? ( dev-python/sphinx )"
-
-src_prepare() {
-       default
-
-       sed -e "s/-Wl,-soname,\$@ //" -i src/build-data/makefile/python.in || die "sed failed"
-       sed \
-               -e "/DOCDIR/d" \
-               -e "/^install:/s/ docs//" \
-               -i src/build-data/makefile/unix_shr.in || die "sed failed"
-
-       # Fix ImportError with Python 3.
-       sed -e "s/_botan/.&/" -i src/wrap/python/__init__.py || die "sed failed"
-
-       use python && python_copy_sources
-}
-
-src_configure() {
-       local disable_modules="proc_walk,unix_procs"
-       use threads || disable_modules+=",pthreads"
-       use bindist && disable_modules+=",ecdsa"
-       elog "Disabling modules: ${disable_modules}"
-
-       # Enable v9 instructions for sparc64
-       if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
-               CHOSTARCH="sparc32-v9"
-       else
-               CHOSTARCH="${CHOST%%-*}"
-       fi
-
-       local myos=
-       case ${CHOST} in
-               *-darwin*)   myos=darwin ;;
-               *)           myos=linux  ;;
-       esac
-
-       # foobared buildsystem, --prefix translates into DESTDIR, see also make
-       # install in src_install, we need the correct live-system prefix here on
-       # Darwin for a shared lib with correct install_name
-       ./configure.py \
-               --prefix="${EPREFIX}/usr" \
-               --libdir=$(get_libdir) \
-               --docdir=share/doc \
-               --cc=gcc \
-               --os=${myos} \
-               --cpu=${CHOSTARCH} \
-               --with-endian="$(tc-endian)" \
-               --without-sphinx \
-               --with-tr1=system \
-               $(use_with bzip2) \
-               $(use_with gmp gnump) \
-               $(use_with python boost-python) \
-               $(use_with ssl openssl) \
-               $(use_with zlib) \
-               --disable-modules=${disable_modules} \
-               || die "configure.py failed"
-}
-
-src_compile() {
-       emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT=""
-
-       if use python; then
-               building() {
-                       rm -fr build/python
-                       ln -s "${BUILD_DIR}" build/python
-                       cp Makefile.python build/python
-                       sed -i \
-                               -e "s/-lboost_python/-lboost_python-$(echo ${EPYTHON} | sed 's/python//')/" \
-                               build/python/Makefile.python
-                       emake -f build/python/Makefile.python \
-                               CXX="$(tc-getCXX)" \
-                               CFLAGS="${CXXFLAGS}" \
-                               LDFLAGS="${LDFLAGS}" \
-                               PYTHON_ROOT="/usr/$(get_libdir)" \
-                               PYTHON_INC="-I$(python_get_includedir)"
-               }
-               python_foreach_impl building
-       fi
-
-       if use doc; then
-               einfo "Generation of documentation"
-               sphinx-build doc doc_output
-       fi
-}
-
-src_test() {
-       chmod -R ugo+rX "${S}"
-       emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check
-       LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
-}
-
-src_install() {
-       emake DESTDIR="${ED}usr" install
-
-       if ! use static-libs; then
-               rm "${ED}usr/$(get_libdir)/libbotan"*.a || die 'remove of static libs failed'
-       fi
-
-       # Add compatibility symlinks.
-       [[ -e "${ED}usr/bin/botan-config" ]] && die "Compatibility code no longer needed"
-       [[ -e "${ED}usr/$(get_libdir)/pkgconfig/botan.pc" ]] && die "Compatibility code no longer needed"
-       dosym botan-config-1.10 /usr/bin/botan-config
-       dosym botan-1.10.pc /usr/$(get_libdir)/pkgconfig/botan.pc
-
-       if use python; then
-               installation() {
-                       rm -fr build/python
-                       ln -s "${BUILD_DIR}" build/python
-                       emake -f Makefile.python \
-                               PYTHON_SITE_PACKAGE_DIR="${ED}$(python_get_sitedir)" \
-                               install
-               }
-               python_foreach_impl installation
-       fi
-
-       if use doc; then
-               pushd doc_output > /dev/null
-               insinto /usr/share/doc/${PF}/html
-               doins -r [a-z]* _static
-               popd > /dev/null
-       fi
-}
diff --git a/dev-libs/botan/files/botan-1.10.14-build.patch b/dev-libs/botan/files/botan-1.10.14-build.patch
deleted file mode 100644 (file)
index 73ee70b..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From d8cb9d52a7e7e7e20cd371349583794e17fd0778 Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Thu, 1 Dec 2016 20:50:35 +0200
-Subject: [PATCH] utils: safeint.h: use botan's to_string
-
-Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
----
- src/utils/safeint.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/utils/safeint.h b/src/utils/safeint.h
-index e0bd662..0a03e4e 100644
---- a/src/utils/safeint.h
-+++ b/src/utils/safeint.h
-@@ -17,7 +17,7 @@ class Integer_Overflow_Detected : public Exception
-    {
-    public:
-       Integer_Overflow_Detected(const std::string& file, int line) :
--         Exception("Integer overflow detected at " + file + ":" + std::to_string(line))
-+         Exception("Integer overflow detected at " + file + ":" + to_string(line))
-          {}
-    };
--- 
-2.7.3
-