dev-db/mysql-connector-c: Use relative include path for udf_registration_types.h
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 23 Aug 2019 00:16:24 +0000 (02:16 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 23 Aug 2019 00:24:13 +0000 (02:24 +0200)
Closes: https://bugs.gentoo.org/692644
Package-Manager: Portage-2.3.72, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-db/mysql-connector-c/files/mysql-connector-c-8.0.17-use-relative-include-path-for-udf_registration_types-h.patch [new file with mode: 0644]
dev-db/mysql-connector-c/mysql-connector-c-8.0.17-r3.ebuild [moved from dev-db/mysql-connector-c/mysql-connector-c-8.0.17-r2.ebuild with 96% similarity]

diff --git a/dev-db/mysql-connector-c/files/mysql-connector-c-8.0.17-use-relative-include-path-for-udf_registration_types-h.patch b/dev-db/mysql-connector-c/files/mysql-connector-c-8.0.17-use-relative-include-path-for-udf_registration_types-h.patch
new file mode 100644 (file)
index 0000000..8fabd99
--- /dev/null
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/692644
+
+--- a/include/mysql.h.pp
++++ b/include/mysql.h.pp
+@@ -175,7 +175,7 @@ struct rand_struct {
+   unsigned long seed1, seed2, max_value;
+   double max_value_dbl;
+ };
+-#include <mysql/udf_registration_types.h>
++#include "mysql/udf_registration_types.h"
+ enum Item_result {
+   INVALID_RESULT = -1,
+   STRING_RESULT = 0,
+--- a/include/mysql_com.h
++++ b/include/mysql_com.h
+@@ -1002,7 +1002,7 @@ struct rand_struct {
+ };
+ /* Include the types here so existing UDFs can keep compiling */
+-#include <mysql/udf_registration_types.h>
++#include "mysql/udf_registration_types.h"
+ /**
+   @addtogroup group_cs_compresson_constants Constants when using compression
similarity index 96%
rename from dev-db/mysql-connector-c/mysql-connector-c-8.0.17-r2.ebuild
rename to dev-db/mysql-connector-c/mysql-connector-c-8.0.17-r3.ebuild
index 3eb18955b0bf9e9201caf8ddb94458e3ce7ea66e..f705146ace586d32923b568fe6a38eacc06c4fe5 100644 (file)
@@ -41,6 +41,7 @@ S="${WORKDIR}/mysql-${PV}"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-8.0.17-always-build-decompress-utilities.patch
+       "${FILESDIR}"/${PN}-8.0.17-use-relative-include-path-for-udf_registration_types-h.patch
        "${FILESDIR}"/${PN}-8.0.17-libressl.patch
 )