dev-libs/libmodbus: bump to v3.1.6
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 2 Mar 2020 15:23:41 +0000 (16:23 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 2 Mar 2020 15:24:07 +0000 (16:24 +0100)
Bug: https://bugs.gentoo.org/704830
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-libs/libmodbus/Manifest
dev-libs/libmodbus/libmodbus-3.1.6.ebuild [new file with mode: 0644]

index e88dd95d3922f55425f51d682f964d93745e2d64..74e7098aa92256277b437c1615a69e56ec2e0089 100644 (file)
@@ -1 +1,2 @@
 DIST libmodbus-3.1.4.tar.gz 471576 BLAKE2B 4fc57abd784e2cfb65d19cd55a31f4b778a209141cc13b9c969dbd6052f187ba0de0031105be748aa2113f345bdb16c2b582b53635b5334f06dfdb34c5992a18 SHA512 63f73894b27704f5e5b3ca0a364cc366c5b5d24903bb24384155890cf06c0f8e5c707a435a38129402ff6628ef3d611dd0db82f840b79cf1d205ebed2ac5681c
+DIST libmodbus-3.1.6.tar.gz 479565 BLAKE2B d9aecb57a0dd274c54a62f707c90c83f31500dd76aefc38c2615d9ce32df659613511e1b567cc385fd2b05aa473dbfbb65ae248d93bb7df2fbfcd7b16b7c5701 SHA512 2e39aea41b1cfb30239c3d8271c68841d645a44a15019090e2efd16979bde373c76532f992aa6a4587b95c65ed9829705f32e698e445df7c0e1d52d0d1165bce
diff --git a/dev-libs/libmodbus/libmodbus-3.1.6.ebuild b/dev-libs/libmodbus/libmodbus-3.1.6.ebuild
new file mode 100644 (file)
index 0000000..1008c8b
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Modbus library which supports RTU communication over a serial line or a TCP link"
+HOMEPAGE="https://libmodbus.org/"
+SRC_URI="https://libmodbus.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test doc"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="doc? ( app-text/asciidoc
+       app-text/xmlto )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.1.4-doc.patch )
+
+src_configure() {
+       econf \
+               $(use_enable test tests) \
+               $(use_enable static-libs static) \
+               $(use_with doc documentation)
+}
+
+src_install() {
+       default
+
+       use static-libs || rm "${ED}"/usr/*/libmodbus.la
+}