net-wireless/bluez: Bump to 5.52
authorPacho Ramos <pacho@gentoo.org>
Sun, 10 Nov 2019 12:06:20 +0000 (13:06 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 10 Nov 2019 12:11:17 +0000 (13:11 +0100)
Also drop obsolete patch (as systemd-m4 package is going to be removed and
was the one causing the issue with variables quoting) and those that were
merged by upstream.

Fix patch for -user-session setups (#698394)

Bug: https://bugs.gentoo.org/698394
Closes: https://bugs.gentoo.org/699234
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
net-wireless/bluez/Manifest
net-wireless/bluez/bluez-5.52.ebuild [new file with mode: 0644]
net-wireless/bluez/files/0001-Allow-using-obexd-without-systemd-in-the-user-session-r2.patch [new file with mode: 0644]

index 042c13a4249c19f2191c0d95a25cc70c5ea1c408..18725c46f414101adb6effdbe6a8894e36b0e090 100644 (file)
@@ -1,3 +1,4 @@
 DIST bluez-5.50-fedora-backports.tar.xz 32232 BLAKE2B 35244036bbe18481e32bef2dcd4a223d44442ce28cee85a3a736bfbf5ee9d74372fa6366dc1102bf86babada608966a8c30b1c2537859a3741c289cabbc76026 SHA512 6d33e8bc67e50dc0d4cee3fa080402a51ddc8b6549f19b6c272de7dc51604eab23f909322f01aaca8a834abdc3cfd0bf24bb8623071af0cf0611d7427c9d8e9a
 DIST bluez-5.50.tar.xz 1755384 BLAKE2B d70763a80fa233cd31fbefc44f73ffceb54c2d7b64ee83df0d2dafb039771d2b18e69dd44b35b2cdf8eee97553c02deca2281f7ec54e958218cf6c4b364a8516 SHA512 64a680e4b3c270bc2439610c91ad2aef36131d84401e4bbdf6c2b7ec8708a19dfc942b31b9189c38a97ca072c761c669ae1aace5f4ff5d06de3ccbf33184be45
 DIST bluez-5.51.tar.xz 1941904 BLAKE2B e8580388961c99305c6f723160e726232a097067815a88a056c1569c55c2ea410004cf92572afbef9b782807d8a940503b4501f9c6046cacac35136fbbe580a8 SHA512 8b14eea98f541b981162abce728e0f917654ad3c990721ec398fe41bdd68069fe55ff64b61bc3c3b9f813facf42c995b07619f6d5d153965de27154b1a7b578f
+DIST bluez-5.52.tar.xz 1957504 BLAKE2B 670cdfb44eca1b184c0bd678bab34116f9172394b86fb69fa454f7bdcc1ae82c466a806879ddef96dddd6ae6cd31466b48f9e87113d43144659ae0c057b9def8 SHA512 9024481910d1dee85578bf3d7a4fc4be2bece516e6216c91aa1a7ac18537f092b47c41c4a5506ddd7e279599d58002e98203c5439745c01df4dbc22a75234c84
diff --git a/net-wireless/bluez/bluez-5.52.ebuild b/net-wireless/bluez/bluez-5.52.ebuild
new file mode 100644 (file)
index 0000000..0529ab6
--- /dev/null
@@ -0,0 +1,281 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools python-single-r1 readme.gentoo-r1 systemd udev multilib-minimal
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://www.bluez.org"
+SRC_URI="https://www.kernel.org/pub/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="btpclient cups doc debug deprecated extra-tools experimental +mesh midi +obex +readline selinux systemd test test-programs +udev user-session"
+
+# Since this release all remaining extra-tools need readline support, but this could
+# change in the future, hence, this REQUIRED_USE constraint could be dropped
+# again in the future.
+REQUIRED_USE="
+       extra-tools? ( deprecated readline )
+       test? ( ${PYTHON_REQUIRED_USE} )
+       test-programs? ( ${PYTHON_REQUIRED_USE} )
+"
+
+TEST_DEPS="${PYTHON_DEPS}
+       >=dev-python/dbus-python-1[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       virtual/pkgconfig
+       test? ( ${TEST_DEPS} )
+"
+DEPEND="
+       >=dev-libs/glib-2.28:2[${MULTILIB_USEDEP}]
+       >=sys-apps/hwids-20121202.2
+       btpclient? ( >=dev-libs/ell-0.26 )
+       cups? ( net-print/cups:= )
+       mesh? (
+               >=dev-libs/ell-0.26
+               dev-libs/json-c:=
+               sys-libs/readline:0=
+       )
+       midi? ( media-libs/alsa-lib )
+       obex? ( dev-libs/libical:= )
+       readline? ( sys-libs/readline:0= )
+       systemd? (
+               >=sys-apps/dbus-1.6:=[user-session=]
+               sys-apps/systemd
+       )
+       !systemd? ( >=sys-apps/dbus-1.6:= )
+       udev? ( >=virtual/udev-172 )
+"
+RDEPEND="${DEPEND}
+       selinux? ( sec-policy/selinux-bluetooth )
+       test-programs? ( ${TEST_DEPS} )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+       # Try both udevadm paths to cover udev/systemd vs. eudev locations (#539844)
+       # http://www.spinics.net/lists/linux-bluetooth/msg58739.html
+       # https://bugs.gentoo.org/539844
+       "${FILESDIR}"/${PN}-udevadm-path-r1.patch
+
+       # Fedora patches
+       # http://www.spinics.net/lists/linux-bluetooth/msg40136.html
+       "${FILESDIR}"/0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
+)
+
+pkg_setup() {
+       if use test || use test-programs; then
+               python-single-r1_pkg_setup
+       fi
+
+       if ! use udev; then
+               ewarn
+               ewarn "You are installing ${PN} with USE=-udev. This means various bluetooth"
+               ewarn "devices and adapters from Apple, Dell, Logitech etc. will not work,"
+               ewarn "and hid2hci will not be available."
+               ewarn
+       fi
+}
+
+src_prepare() {
+       default
+
+       # http://www.spinics.net/lists/linux-bluetooth/msg38490.html
+       if ! use user-session || ! use systemd; then
+               eapply "${FILESDIR}"/0001-Allow-using-obexd-without-systemd-in-the-user-session-r2.patch
+       fi
+
+       if use cups; then
+               sed -i \
+                       -e "s:cupsdir = \$(libdir)/cups:cupsdir = $(cups-config --serverbin):" \
+                       Makefile.{in,tools} || die
+       fi
+
+       # Broken test https://bugzilla.kernel.org/show_bug.cgi?id=196621
+       # https://bugs.gentoo.org/618548
+       sed -i -e '/unit_tests += unit\/test-gatt\b/d' Makefile.am || die
+
+       eautoreconf
+
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       local myconf=(
+               # readline is automagic when client is enabled
+               # --enable-client always needs readline, bug #504038
+               # --enable-mesh is handled in the same way
+               ac_cv_header_readline_readline_h=$(multilib_native_usex readline)
+               ac_cv_header_readline_readline_h=$(multilib_native_usex mesh)
+       )
+
+       if ! multilib_is_native_abi; then
+               myconf+=(
+                       # deps not used for the library
+                       {DBUS,GLIB}_{CFLAGS,LIBS}=' '
+               )
+       fi
+
+       econf \
+               --localstatedir=/var \
+               --disable-android \
+               --enable-datafiles \
+               --enable-optimization \
+               $(use_enable debug) \
+               --enable-pie \
+               --enable-threads \
+               --enable-library \
+               --enable-tools \
+               --enable-manpages \
+               --enable-monitor \
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+               --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+               $(multilib_native_use_enable btpclient) \
+               $(multilib_native_use_enable btpclient external-ell) \
+               $(multilib_native_use_enable cups) \
+               $(multilib_native_use_enable deprecated) \
+               $(multilib_native_use_enable experimental) \
+               $(multilib_native_use_enable mesh) \
+               $(multilib_native_use_enable mesh external-ell) \
+               $(multilib_native_use_enable midi) \
+               $(multilib_native_use_enable obex) \
+               $(multilib_native_use_enable readline client) \
+               $(multilib_native_use_enable systemd) \
+               $(multilib_native_use_enable test-programs test) \
+               $(multilib_native_use_enable udev) \
+               $(multilib_native_use_enable udev sixaxis)
+}
+
+multilib_src_compile() {
+       if multilib_is_native_abi; then
+               default
+       else
+               emake -f Makefile -f - libs \
+                       <<<'libs: $(lib_LTLIBRARIES)'
+       fi
+}
+
+multilib_src_test() {
+       multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+       if multilib_is_native_abi; then
+               emake DESTDIR="${D}" install
+
+               # Only install extra-tools when relevant USE flag is enabled
+               if use extra-tools; then
+                       ewarn "Upstream doesn't support using this tools and their bugs are"
+                       ewarn "likely to be ignored forever, also that tools can break"
+                       ewarn "without previous announcement."
+                       ewarn "Upstream also states all this tools are not really needed,"
+                       ewarn "then, if you still need to rely on them, you must ask them"
+                       ewarn "to either install that tool by default or add the needed"
+                       ewarn "functionality to the existing 'official' tools."
+                       ewarn "Please report this issues to:"
+                       ewarn "http://www.bluez.org/development/lists/"
+
+                       # Upstream doesn't install this, bug #524640
+                       # http://permalink.gmane.org/gmane.linux.bluez.kernel/53115
+                       # http://comments.gmane.org/gmane.linux.bluez.kernel/54564
+                       dobin tools/btmgmt
+                       # gatttool is only built with readline, bug #530776
+                       # https://bugzilla.redhat.com/show_bug.cgi?id=1141909
+                       # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=720486
+                       # https://bugs.archlinux.org/task/37686
+                       dobin attrib/gatttool
+                       # https://bugzilla.redhat.com/show_bug.cgi?id=1699680
+                       dobin tools/avinfo
+               fi
+
+               # Not installed by default after being built, bug #666756
+               use btpclient && dobin tools/btpclient
+
+               # Unittests are not that useful once installed, so make them optional
+               if use test-programs; then
+                       # Few are needing python3, the others are python2 only. Remove
+                       # until we see how to pull in python2 and python3 for runtime
+                       rm "${ED}"/usr/$(get_libdir)/bluez/test/example-gatt-server || die
+                       rm "${ED}"/usr/$(get_libdir)/bluez/test/example-gatt-client || die
+                       rm "${ED}"/usr/$(get_libdir)/bluez/test/agent.py || die
+                       rm "${ED}"/usr/$(get_libdir)/bluez/test/test-mesh || die
+
+                       python_fix_shebang "${ED}"/usr/$(get_libdir)/bluez/test
+
+                       for i in $(find "${ED}"/usr/$(get_libdir)/bluez/test -maxdepth 1 -type f ! -name "*.*"); do
+                               dosym "${i}" /usr/bin/bluez-"${i##*/}"
+                       done
+               fi
+       else
+               emake DESTDIR="${D}" \
+                       install-pkgincludeHEADERS \
+                       install-libLTLIBRARIES \
+                       install-pkgconfigDATA
+       fi
+}
+
+multilib_src_install_all() {
+       # We need to ensure obexd can be spawned automatically by systemd
+       # when user-session is enabled:
+       # http://marc.info/?l=linux-bluetooth&m=148096094716386&w=2
+       # https://bugs.gentoo.org/show_bug.cgi?id=577842
+       # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804908
+       # https://bugs.archlinux.org/task/45816
+       # https://bugzilla.redhat.com/show_bug.cgi?id=1318441
+       # https://bugzilla.redhat.com/show_bug.cgi?id=1389347
+       if use user-session && use systemd; then
+               ln -s "${ED}"/usr/lib/systemd/user/obex.service "${ED}"/usr/lib/systemd/user/dbus-org.bluez.obex.service
+       fi
+
+       find "${D}" -name '*.la' -type f -delete || die
+
+       keepdir /var/lib/bluetooth
+
+       # Upstream don't want people to play with them
+       # But we keep installing them due to 'historical' reasons
+       insinto /etc/bluetooth
+       local d
+       for d in input network; do
+               doins profiles/${d}/${d}.conf
+       done
+       # Setup auto enable as Fedora does for allowing to use
+       # keyboards/mouse as soon as possible
+       sed -i 's/#\[Policy\]$/\[Policy\]/; s/#AutoEnable=false/AutoEnable=true/' src/main.conf || die
+       doins src/main.conf
+
+       newinitd "${FILESDIR}"/bluetooth-init.d-r4 bluetooth
+
+       einstalldocs
+       use doc && dodoc doc/*.txt
+       # Install .json files as examples to be used by meshctl
+       if use mesh; then
+               dodoc tools/mesh/*.json
+               local DOC_CONTENTS="Some example .json files were installed into
+               /usr/share/doc/${PF} to be used with meshctl. Feel free to
+               uncompress and copy them to ~/.config/meshctl to use them."
+               readme.gentoo_create_doc
+       fi
+
+       # From Fedora:
+       # Scripts for automatically btattach-ing serial ports connected to Broadcom HCIs
+       # as found on some Atom based x86 hardware
+       udev_dorules "${FILESDIR}/69-btattach-bcm.rules"
+       systemd_newunit "${FILESDIR}/btattach-bcm_at.service" "btattach-bcm@.service"
+       exeinto /usr/libexec/bluetooth
+       doexe "${FILESDIR}/btattach-bcm-service.sh"
+}
+
+pkg_postinst() {
+       use udev && udev_reload
+       systemd_reenable bluetooth.service
+
+       has_version net-dialup/ppp || elog "To use dial up networking you must install net-dialup/ppp"
+       use mesh && readme.gentoo_print_elog
+}
diff --git a/net-wireless/bluez/files/0001-Allow-using-obexd-without-systemd-in-the-user-session-r2.patch b/net-wireless/bluez/files/0001-Allow-using-obexd-without-systemd-in-the-user-session-r2.patch
new file mode 100644 (file)
index 0000000..dcebaa0
--- /dev/null
@@ -0,0 +1,58 @@
+From 3027cb7141fb65cf3eeda69c688db8c4045e2d3f Mon Sep 17 00:00:00 2001
+From: Giovanni Campagna <gcampagna-cNUdlRotFMnNLxjTenLetw@public.gmane.org>
+Date: Sat, 12 Oct 2013 17:45:25 +0200
+Subject: [PATCH] Allow using obexd without systemd in the user session
+
+Not all sessions run systemd --user (actually, the majority
+doesn't), so the dbus daemon must be able to spawn obexd
+directly, and to do so it needs the full path of the daemon.
+---
+ Makefile.obexd                      | 4 ++--
+ obexd/src/org.bluez.obex.service    | 4 ----
+ obexd/src/org.bluez.obex.service.in | 4 ++++
+ 3 files changed, 6 insertions(+), 6 deletions(-)
+ delete mode 100644 obexd/src/org.bluez.obex.service
+ create mode 100644 obexd/src/org.bluez.obex.service.in
+
+diff --git a/Makefile.obexd b/Makefile.obexd
+index 3760867..142e7c3 100644
+--- a/Makefile.obexd
++++ b/Makefile.obexd
+@@ -2,12 +2,12 @@
+ if SYSTEMD
+ systemduserunitdir = $(SYSTEMD_USERUNITDIR)
+ systemduserunit_DATA = obexd/src/obex.service
++endif
+ dbussessionbusdir = $(DBUS_SESSIONBUSDIR)
+ dbussessionbus_DATA = obexd/src/org.bluez.obex.service
+-endif
+-EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service
++EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service.in
+ obex_plugindir = $(libdir)/obex/plugins
+diff --git a/obexd/src/org.bluez.obex.service b/obexd/src/org.bluez.obex.service
+deleted file mode 100644
+index a538088..0000000
+--- a/obexd/src/org.bluez.obex.service
++++ /dev/null
+@@ -1,4 +0,0 @@
+-[D-BUS Service]
+-Name=org.bluez.obex
+-Exec=/bin/false
+-SystemdService=dbus-org.bluez.obex.service
+diff --git a/obexd/src/org.bluez.obex.service.in b/obexd/src/org.bluez.obex.service.in
+new file mode 100644
+index 0000000..9c815f2
+--- /dev/null
++++ b/obexd/src/org.bluez.obex.service.in
+@@ -0,0 +1,4 @@
++[D-BUS Service]
++Name=org.bluez.obex
++Exec=@pkglibexecdir@/obexd
++SystemdService=dbus-org.bluez.obex.service
+-- 
+1.8.3.1
+