xfce-base/xfce4-panel: Bump to 4.15.0
authorMichał Górny <mgorny@gentoo.org>
Sun, 20 Oct 2019 11:01:56 +0000 (13:01 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 20 Oct 2019 11:07:29 +0000 (13:07 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-base/xfce4-panel/Manifest
xfce-base/xfce4-panel/xfce4-panel-4.15.0.ebuild [new file with mode: 0644]

index 3a52dd2c40c1168d2eb4e2e010fe957528d1973b..1b3bda547be534ee323fbb7b686d5dd27c3246ad 100644 (file)
@@ -1 +1,2 @@
 DIST xfce4-panel-4.14.1.tar.bz2 1294087 BLAKE2B d88100d068348aab32f7a133ca98e17c1586f3d6c5ffcb53493e953930108d4d1ebd0972d84c4bd077ab58c4a3ae34303682084daff4e34a168c5c2f981597bf SHA512 1c86362489677f2e04cf3b98dbc1a80b4998335c00a47d256e741446f00437ad04539041648848eca1f45fa1fa70974ca6cf65cb7f762a79a46c16484557e400
+DIST xfce4-panel-4.15.0.tar.bz2 1271290 BLAKE2B 6062ed76d8372f5e1ab9def67bcc8c4006ef269309b47740c331c8afef8f320069478846e802c6a090c4a6aa465d79c75e028d52b8f09dd8e1dafa11c8d415ec SHA512 3f4d9a097cb9b9a4ec4296b518e91b13394ca063664c78768dc3e2a964090177485c189c3ff3e118b179d58aafdb27d2edf67ddb49434290eaed157b449fc817
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.15.0.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.15.0.ebuild
new file mode 100644 (file)
index 0000000..b4d4d73
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala xdg-utils
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42
+       >=x11-libs/cairo-1
+       >=x11-libs/gtk+-3.22:3[introspection?]
+       x11-libs/libX11
+       x11-libs/libwnck:3
+       >=xfce-base/exo-0.11.2:=
+       >=xfce-base/garcon-0.5:=
+       >=xfce-base/libxfce4ui-4.13:=
+       >=xfce-base/libxfce4util-4.13:=[introspection?]
+       >=xfce-base/xfconf-4.13:=
+       introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+       vala? ( $(vala_depend) )
+       dev-lang/perl
+       dev-util/gtk-doc-am
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_prepare() {
+       # stupid vala.eclass...
+       default
+}
+
+src_configure() {
+       local myconf=(
+               $(use_enable introspection)
+               $(use_enable vala)
+       )
+
+       use vala && vala_src_prepare
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+       xdg_desktop_database_update
+}