Removing obsolete versions. Inheriting java-pkg-2 avoiding errors with a JRE as VM...
authorSandro Bonazzola <sanchan@gentoo.org>
Tue, 14 Nov 2006 21:32:58 +0000 (21:32 +0000)
committerSandro Bonazzola <sanchan@gentoo.org>
Tue, 14 Nov 2006 21:32:58 +0000 (21:32 +0000)
Package-Manager: portage-2.1.2_rc1-r6

dev-tinyos/nesc/ChangeLog
dev-tinyos/nesc/files/nesc-1.2.7a-alignment.patch [new file with mode: 0644]
dev-tinyos/nesc/nesc-1.2.7a.ebuild

index 702570e9d2a826169962068e9c2d8dcffce65e96..78bf3b3bfe1faec8617642c32188f1b03cf5def9 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-tinyos/nesc
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/ChangeLog,v 1.11 2006/08/10 20:20:48 sanchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/ChangeLog,v 1.12 2006/11/14 21:32:58 sanchan Exp $
+
+  14 Nov 2006; Sandro Bonazzola <sanchan@gentoo.org>
+  +files/nesc-1.2.7a-alignment.patch, -nesc-1.2.4-r1.ebuild,
+  -nesc-1.2.5-r1.ebuild, nesc-1.2.7a.ebuild:
+  Removing obsolete versions. Inheriting java-pkg-2 avoiding errors with a JRE
+  as VM. Adding patch provided by AurĂ©lien Francillon fixing bug #145870.
+  Keywording ~amd64.
 
   10 Aug 2006; Sandro Bonazzola <sanchan@gentoo.org> nesc-1.2.7a.ebuild:
   Fix missing dependency on media-gfx/graphviz, add some info about editor
diff --git a/dev-tinyos/nesc/files/nesc-1.2.7a-alignment.patch b/dev-tinyos/nesc/files/nesc-1.2.7a-alignment.patch
new file mode 100644 (file)
index 0000000..c540960
--- /dev/null
@@ -0,0 +1,30 @@
+--- src/attributes.c-old       2006-09-05 18:52:23.000000000 +0200
++++ src/attributes.c   2006-09-05 19:40:23.000000000 +0200
+@@ -69,9 +69,6 @@
+       return cval_cast(arg, size_t_type);
+     else
+       error("requested alignment is not a power of 2");
+-  else
+-    error("requested alignment is not a constant");
+-
+   return cval_top;
+ }
+@@ -146,13 +143,10 @@
+     {
+       cval arg = get_alignment(attr);
+-      if (cval_isinteger(arg))
+-      {
+-        if (ddecl->kind == decl_variable || ddecl->kind == decl_typedef)
+-          ddecl->type = align_type(ddecl->type, arg);
+-        else
+-          ignored_gcc_attribute(attr);
+-      }
++      if (cval_isinteger(arg) &&  (ddecl->kind == decl_variable || ddecl->kind == decl_typedef))
++      ddecl->type = align_type(ddecl->type, arg);
++      else
++      ignored_gcc_attribute(attr);
+     }
+   else if (is_attr_name(name, "mode"))
+     {
index f3c629fc6e05509837f9a968c073eea60b67c10f..e7e6fc9feda78fbbc234cc38229ee9637055953a 100644 (file)
@@ -1,15 +1,15 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/nesc-1.2.7a.ebuild,v 1.2 2006/08/10 20:20:48 sanchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/nesc-1.2.7a.ebuild,v 1.3 2006/11/14 21:32:58 sanchan Exp $
 
-inherit eutils
+inherit eutils java-pkg-2
 
 DESCRIPTION="An extension to gcc that knows how to compile nesC applications"
 HOMEPAGE="http://nescc.sourceforge.net/"
 SRC_URI="mirror://sourceforge/nescc/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
 IUSE="doc"
 DEPEND=">=dev-lang/perl-5.8.5-r2
        >=dev-tinyos/tos-1.1.0
@@ -39,6 +39,13 @@ pkg_setup() {
        else
                einfo "Building nesC for ${TOSDIR}"
        fi
+       java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}"/${P}-alignment.patch
 }
 
 src_compile() {