dev-perl/URI: Bump to version 1.730.0
authorKent Fredric <kentnl@gentoo.org>
Mon, 19 Mar 2018 00:58:51 +0000 (13:58 +1300)
committerKent Fredric <kentnl@gentoo.org>
Mon, 19 Mar 2018 06:39:05 +0000 (19:39 +1300)
Upstream:
- Packaging and Test changes
- Documentation fixes

Keywords:
- Dropped many due to new Test-Needs dep, some were already busted
  due to arm-linux not having even perl keyworded.
- Dropped: amd64-fbsd, arm-linux, m68k, mips, s390, sh, sparc-solaris,
  sparc64-solaris, x64-cygwin, x64-solaris

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/URI/Manifest
dev-perl/URI/URI-1.730.0.ebuild [new file with mode: 0644]

index fbd4d2a00e7bc1f6db62596bce67541649db7ff5..9435e6a13bb06d18896c37ccf0e6add3ca1aa8d8 100644 (file)
@@ -1 +1,2 @@
 DIST URI-1.71.tar.gz 100141 BLAKE2B 8efc84c878c96a6ddb52d6ff91df3003125db2780c295070f2012739d3154d6692326dceda8acee5078b11bca5ca65094b1567178d2a7372b3768c74b2a94e0a SHA512 db412b75054a4d315eb861060fa4641832c2428b9dfe56bbe35f530c9ba572d4de2061d9782454750293dd5a64f3375830988d8512f410e84a9d599c80458405
+DIST URI-1.73.tar.gz 106930 BLAKE2B 85adc080b463d67142c96e7ab7af13ff4a231054f28976edb8d7746cd9d788693f1cc2f1b30658530634e2693bc76bbdb47b1dfb6a6caca89117bd92aa78b910 SHA512 b72d07e9e9e284f360ad4bf42b22ddec2d1930be40ec465ca28c68484e87b01c55ab664cdec63af387bc435e9428681c64aed39b46b668d7c7c5f36be5fbeb2e
diff --git a/dev-perl/URI/URI-1.730.0.ebuild b/dev-perl/URI/URI-1.730.0.ebuild
new file mode 100644 (file)
index 0000000..1b87152
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=1.73
+inherit perl-module
+
+DESCRIPTION="Uniform Resource Identifiers (absolute and relative)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+       virtual/perl-Carp
+       virtual/perl-Data-Dumper
+       virtual/perl-Encode
+       >=virtual/perl-Exporter-5.570.0
+       virtual/perl-File-Spec
+       >=virtual/perl-MIME-Base64-2
+       virtual/perl-Scalar-List-Utils
+       virtual/perl-libnet
+       virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-File-Temp
+               virtual/perl-Test
+               dev-perl/Test-Needs
+               >=virtual/perl-Test-Simple-0.960.0
+       )
+"