x11-libs/libpciaccess: Version bump to 0.16
authorMatt Turner <mattst88@gentoo.org>
Wed, 17 Jul 2019 18:25:49 +0000 (11:25 -0700)
committerMatt Turner <mattst88@gentoo.org>
Wed, 17 Jul 2019 18:27:24 +0000 (11:27 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/libpciaccess/Manifest
x11-libs/libpciaccess/libpciaccess-0.16.ebuild [new file with mode: 0644]

index e6e434bcd3e43ecd7748600e1ac2b83daf66dc73..8bbf32012afe8b7b846c6104de0beeef02a1fbd5 100644 (file)
@@ -1,2 +1,3 @@
 DIST libpciaccess-0.14.tar.bz2 361375 BLAKE2B 05af836e52c7a8e19537a5c246f2dbbfee0a8c078ed0d6c45de6d1cc5f07b70d91b9409846b175da74f31b0e2536e38ffcb65983d79d40a54abc878b679d845d SHA512 bf40214dfd22f2a223f7c948566e6eaa4bfed60116e71b3eb19f6fe7ab2c4546649eb0416c06d5983e476ea5e27de036936646eb5f800ea97763b6d1f1976f4b
 DIST libpciaccess-0.15.tar.bz2 366454 BLAKE2B 8a17a7178e735b17e726fd0fd02235e9059228fd369e2569071167ec54ae88f042032628660db6b7558845600cec67237598d648abe11ef99acedd1ad1c8bef5 SHA512 c34abc438c549db22d27d71d63e13f93cb547eaea238ff2d193627b83a5877e2b34f6fcf4cdaf9b4f0c6b78206447fd9a578454783cfb4e9010e8de20de1364e
+DIST libpciaccess-0.16.tar.bz2 366603 BLAKE2B aab7d49887f7f21e0a6abf1e2aedc50159a47c7aef67eb8605a30e246463a14f9a9993db9cbd2705ef59c93d1ff41080668f8f3723557a927ab4d1edb5dfa4ad SHA512 2f250048a270dfc0823d4bdd613aa272c58a80eaafd922850f56c4b6f7a45a263ed4cf521b52b49f04484ea44ebefb7407d079aa058318a5751ffb181e38fed1
diff --git a/x11-libs/libpciaccess/libpciaccess-0.16.ebuild b/x11-libs/libpciaccess/libpciaccess-0.16.ebuild
new file mode 100644 (file)
index 0000000..553bc41
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="Library providing generic access to the PCI bus and devices"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="zlib"
+
+DEPEND="!<x11-base/xorg-server-1.5
+       zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+       sys-apps/hwids"
+
+pkg_setup() {
+       XORG_CONFIGURE_OPTIONS=(
+               "$(use_with zlib)"
+               "--with-pciids-path=${EPREFIX}/usr/share/misc"
+       )
+}
+
+multilib_src_install() {
+       default
+
+       if multilib_is_native_abi; then
+               dodir /usr/bin
+               ${BASH} libtool --mode=install "$(type -P install)" -c scanpci/scanpci "${ED}"/usr/bin || die
+       fi
+}