app-admin/puppet-agent: 6.13.0 fast stable for CVE-2020-7942
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 1 Mar 2020 02:55:32 +0000 (20:55 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 1 Mar 2020 02:57:16 +0000 (20:57 -0600)
Has cleanup as well

Bug: https://bugs.gentoo.org/711138
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-admin/puppet-agent/Manifest
app-admin/puppet-agent/metadata.xml
app-admin/puppet-agent/puppet-agent-6.12.0.ebuild [deleted file]
app-admin/puppet-agent/puppet-agent-6.13.0.ebuild

index 0a4ed30d8850307c81642ae45f302978a0f44dbc..00b406eabb8a12cad7a781357408409c1e8b3c6a 100644 (file)
@@ -1,4 +1,2 @@
-DIST puppet-agent_6.12.0-1stretch_amd64.deb 20011636 BLAKE2B f83b795f07771d70220cac71d9b6d8ac7270a20fd5b78471ccef1c8ff802af3c035477f7741e775b10bc609d016a6e9fb79b199987e34b7d4f9a427c4adcd39f SHA512 dda8fa45b961d4a775da7eb128887eee3ceb9887d1062bc2fc748f6055811600162dfb2c4fbf87e401ad404813d2de0cc58ce7aade0aa23af637bb3707896126
-DIST puppet-agent_6.12.0-1stretch_i386.deb 20369446 BLAKE2B f01e39a1b307657569084e2ade1d41f17eefaa2048035f635437159e4373386c6413fa71756594d4a8748ffa0bbbdc2c54c72e696a390380bc9c57721ef010b3 SHA512 fc58e5ea22bd3dd36278db37e46d20809e284db5645ab680fb2c461ee9e4f9e635550f924278905ec13a8f9a71fbf604959e8522e4c0da52709c42f309a04921
 DIST puppet-agent_6.13.0-1stretch_amd64.deb 22432484 BLAKE2B 231f8683afbf4d2c5ded7bfec323baecbfd52446bb3483c2c16764bc57b79a18d256ecf94b27d4db1bbe88038d7f3eef037c500a39e3b66d641e4effa94cd2d3 SHA512 6101e84e5dbfa64bd336bb23595fe559165e4a159fa5de739aa1617e6825ab11ad62d1abbee26ff94b9f68caa7a192c0339a0c721efcc534ae9ddbba161af907
 DIST puppet-agent_6.13.0-1stretch_i386.deb 22787442 BLAKE2B 1bcea00b2da5c5b0db51fdd12d3828492a9a56af3a8c84919258ac7b90f7d135df708aba602a6d517364ac8b42f1ee3f1c11596cca0e89809a72d1d04c7ecc58 SHA512 55afd1ec6d331808a2a5adcd9c41803d932bcd7e2653da42c81c8ea1179649ae7ac642993813d527b2f365fb4f21d67015a0c2eb5379de2184585475521f8726
index aef6ae7f136ccbcd17454e1328fbfbe948d3296c..7ac132fb0a532ca20824099d48450f1454562bda 100644 (file)
@@ -9,6 +9,16 @@
                <flag name="puppetdb">Adds puppetdb support</flag>
        </use>
        <longdescription lang="en">
-               Collection of puppet utils, clients and batteries included.
+               Centralised configuration management for networks
+               Puppet lets you centrally manage every important aspect of your system
+               using a cross-platform specification language that manages all the
+               separate elements normally aggregated in different files, like users,
+               cron jobs, and hosts, along with obviously discrete elements like
+               packages, services, and files.
+
+               Puppet's simple declarative specification language provides powerful
+               classing abilities for drawing out the similarities between hosts while
+               allowing them to be as specific as necessary, and it handles dependency
+               and prerequisite relationships between objects clearly and explicitly.
        </longdescription>
 </pkgmetadata>
diff --git a/app-admin/puppet-agent/puppet-agent-6.12.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.12.0.ebuild
deleted file mode 100644 (file)
index 166b77d..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit eutils systemd unpacker user
-
-DESCRIPTION="general puppet client utils along with hiera and facter"
-HOMEPAGE="https://puppetlabs.com/"
-SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
-SRC_URI="
-       amd64? ( ${SRC_BASE}_amd64.deb )
-       x86?   ( ${SRC_BASE}_i386.deb )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="puppetdb selinux"
-RESTRICT="strip"
-
-CDEPEND="!app-admin/puppet
-       !dev-ruby/hiera
-       !dev-ruby/facter
-       !app-emulation/virt-what"
-
-DEPEND="
-       ${CDEPEND}
-       app-admin/augeas"
-RDEPEND="${CDEPEND}
-       app-portage/eix
-       sys-apps/dmidecode
-       sys-libs/glibc
-       sys-libs/readline:0/7
-       sys-libs/ncurses:0[tinfo]
-       selinux? (
-               sys-libs/libselinux[ruby]
-               sec-policy/selinux-puppet
-       )
-       puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
-
-S=${WORKDIR}
-
-pkg_setup() {
-       enewgroup puppet
-       enewuser puppet -1 -1 /var/run/puppet puppet
-}
-
-src_install() {
-       # conf.d
-       doconfd etc/default/puppet
-       doconfd etc/default/pxp-agent
-       # logrotate.d
-       insinto /etc/logrotate.d
-       doins etc/logrotate.d/pxp-agent
-       # puppet itself
-       insinto /etc/puppetlabs
-       doins -r etc/puppetlabs/*
-       # logdir for systemd
-       dodir var/log/puppetlabs/puppet/
-       fperms 0750 var/log/puppetlabs/puppet/
-       # the rest
-       insinto /opt
-       dodir opt/puppetlabs/puppet/cache
-       doins -r opt/*
-       fperms 0750 /opt/puppetlabs/puppet/cache
-       # init
-       newinitd "${FILESDIR}/puppet.initd" puppet
-       systemd_dounit lib/systemd/system/puppet.service
-       systemd_dounit lib/systemd/system/pxp-agent.service
-       systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
-       # symlinks
-       chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
-       chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
-       dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
-       dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
-       dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
-       dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
-}
index 6ef50802412924a06d128a4c71bda11b078cd141..9d360f3dc1b33ad9a4ccbe974a04245c89db5f9a 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="puppetdb selinux"
 RESTRICT="strip"