app-admin/verynice: epatch->eapply
authorMarty E. Plummer <hanetzer@startmail.com>
Fri, 20 Apr 2018 07:56:31 +0000 (02:56 -0500)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Apr 2018 20:00:39 +0000 (22:00 +0200)
Also removed eutils; verynice-1.1-r2 only requires epatch externally,
and verynice-1.1.-r3 doesn't require it at all.

Package-Manager: Portage-2.3.28, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/8081

app-admin/verynice/files/verynice-1.1-build.patch
app-admin/verynice/verynice-1.1-r2.ebuild
app-admin/verynice/verynice-1.1-r3.ebuild

index a70202b9930045c732db8ca3afe58cd1cc85d1e2..3782c74a5c054bcff934a91dbb947e535c6ecf2e 100644 (file)
@@ -5,8 +5,8 @@ Subject: build system
 respect flags, add LDFLAGS to linker line
 fix install rules
 
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
 @@ -15,13 +15,15 @@
  #    along with this program; if not, write to the Free Software
  #    Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
index d4536a3b895edf96f54038fcbc0ee316d4d0105c..e9dc02e399c0fa314bbc02f3a5b8ce8c7a1fb45e 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=5
 
-inherit eutils systemd toolchain-funcs
+inherit epatch systemd toolchain-funcs
 
 DESCRIPTION="A tool for dynamically adjusting the nice-level of processes"
 HOMEPAGE="https://web.archive.org/web/2010033109/http://thermal.cnde.iastate.edu/~sdh4/verynice/"
@@ -17,7 +17,7 @@ IUSE=""
 S=${WORKDIR}/${PN}
 
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-build.patch
+       epatch "${FILESDIR}"/${PN}-1.1-build.patch
 }
 
 src_compile() {
index b6334a5e2815da7cebb1031dbe9595a81f91967b..7aba33fc8dc2ad08e0fa0140e37d8910f6e26ffc 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit eutils systemd toolchain-funcs
+inherit systemd toolchain-funcs
 
 DESCRIPTION="A tool for dynamically adjusting the nice-level of processes"
 HOMEPAGE="https://web.archive.org/web/20130621090315/http://thermal.cnde.iastate.edu/~sdh4/verynice/"
@@ -16,10 +16,9 @@ IUSE=""
 
 S=${WORKDIR}/${PN}
 
-src_prepare() {
-       default
-       epatch "${FILESDIR}"/${P}-build.patch
-}
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.1-build.patch
+)
 
 src_compile() {
        tc-export CC