dev-util/cmake: suppress CPackDEB tests in 3.13.5 too
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 4 Jul 2019 18:13:40 +0000 (20:13 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 4 Jul 2019 19:36:07 +0000 (21:36 +0200)
Closes: https://bugs.gentoo.org/611016
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-util/cmake/cmake-3.13.5.ebuild

index 87519fed19c451eda8fa518961ba02568698764d..34b8a855e623915ba9b6e708beba5ba84ab77746 100644 (file)
@@ -121,12 +121,14 @@ cmake_src_test() {
        #    RunCMake.CompilerLauncher: also requires fortran
        #    RunCMake.CPack_RPM: breaks if app-arch/rpm is installed because
        #        debugedit binary is not in the expected location
+       #    RunCMake.CPack_DEB: breaks if app-arch/dpkg is installed because
+       #        it can't find a deb package that owns libc
        #    TestUpload, which requires network access
        "${BUILD_DIR}"/bin/ctest \
                -j "$(makeopts_jobs)" \
                --test-load "$(makeopts_loadavg)" \
                ${ctestargs} \
-               -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.CPack_RPM|TestUpload)" \
+               -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
                || die "Tests failed"
 
        popd > /dev/null