dev-python/scandir: Works with py3.7
authorAlexey Shvetsov <alexxy@gentoo.org>
Sun, 4 Aug 2019 13:30:04 +0000 (16:30 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Sun, 4 Aug 2019 13:30:04 +0000 (16:30 +0300)
Package-Manager: Portage-2.3.70, Repoman-2.3.16
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
dev-python/scandir/scandir-1.10.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/scandir/scandir-1.10.0-r1.ebuild b/dev-python/scandir/scandir-1.10.0-r1.ebuild
new file mode 100644 (file)
index 0000000..7de4dbb
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A better directory iterator and faster os.walk()"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+}