version bump thanks to James Cloos <cloos@jhcloos.com> in bug 174268
authorStefan Schweizer <genstef@gentoo.org>
Fri, 13 Apr 2007 21:26:47 +0000 (21:26 +0000)
committerStefan Schweizer <genstef@gentoo.org>
Fri, 13 Apr 2007 21:26:47 +0000 (21:26 +0000)
Package-Manager: portage-2.1.2.3

net-wireless/wireless-tools/ChangeLog
net-wireless/wireless-tools/files/digest-wireless-tools-29_pre17 [new file with mode: 0644]
net-wireless/wireless-tools/wireless-tools-29_pre17.ebuild [new file with mode: 0644]

index dc71f07c015c857e66fd4685b120c0026f9a408d..25c0d9b4430a770831416724563d19e1fe629ce4 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-wireless/wireless-tools
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wireless-tools/ChangeLog,v 1.111 2006/10/15 21:26:36 agriffis Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wireless-tools/ChangeLog,v 1.112 2007/04/13 21:26:47 genstef Exp $
+
+*wireless-tools-29_pre17 (13 Apr 2007)
+
+  13 Apr 2007; Stefan Schweizer <genstef@gentoo.org>
+  +wireless-tools-29_pre17.ebuild:
+  version bump thanks to James Cloos <cloos@jhcloos.com> in bug 174268
 
   15 Oct 2006; Aron Griffis <agriffis@gentoo.org>
   wireless-tools-29_pre10.ebuild:
diff --git a/net-wireless/wireless-tools/files/digest-wireless-tools-29_pre17 b/net-wireless/wireless-tools/files/digest-wireless-tools-29_pre17
new file mode 100644 (file)
index 0000000..f741635
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 8e77298f8335ff1a5dd6ceefd40a8f1b wireless_tools.29.pre17.tar.gz 279974
+RMD160 eeeacd6c9d5a339f9200553dc3dced3148b2bc1f wireless_tools.29.pre17.tar.gz 279974
+SHA256 47049db73cc89f3e7e89164e62675656382ddc3c488c91be59ed235c6645888c wireless_tools.29.pre17.tar.gz 279974
diff --git a/net-wireless/wireless-tools/wireless-tools-29_pre17.ebuild b/net-wireless/wireless-tools/wireless-tools-29_pre17.ebuild
new file mode 100644 (file)
index 0000000..9a060d2
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wireless-tools/wireless-tools-29_pre17.ebuild,v 1.1 2007/04/13 21:26:47 genstef Exp $
+
+inherit toolchain-funcs multilib
+
+# The following works with both pre-releases and releases
+MY_P=${PN/-/_}.${PV/_/.}
+S=${WORKDIR}/${MY_P/\.pre*/}
+
+DESCRIPTION="A collection of tools to configure IEEE 802.11 wireless LAN cards"
+HOMEPAGE="http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html"
+SRC_URI="http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="multicall nls"
+
+DEPEND="sys-apps/sed"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+       unpack ${A}
+
+       sed -i \
+               -e "s:^\(CC\) = gcc:\1 = $(tc-getCC):" \
+               -e "s:^\(AR\) = ar:\1 = $(tc-getAR):" \
+               -e "s:^\(RANLIB\) = ranlib:\1 = $(tc-getRANLIB):" \
+               -e "s:^\(CFLAGS=-Os\):#\1:" \
+               -e "s:\(@\$(LDCONFIG).*\):#\1:" \
+               -e "s:^\(INSTALL_MAN= \$(PREFIX)\)/man/:\1/share/man:" \
+               -e "s:^\(INSTALL_LIB= \$(PREFIX)\)/lib/:\1/$(get_libdir)/:" \
+               "${S}"/Makefile || die
+}
+
+src_compile() {
+       emake || die "emake failed"
+
+       if use multicall; then
+               emake iwmulticall || die "emake iwmulticall failed"
+       fi
+}
+
+src_install() {
+       make PREFIX="${D}" INSTALL_INC="${D}"/usr/include INSTALL_MAN="${D}"/usr/share/man install \
+               || die "make install failed"
+
+       if use multicall; then
+               # 'make install-iwmulticall' will overwrite some of the tools
+               # with symlinks - this is intentional (brix)
+               make PREFIX="${D}" INSTALL_INC="${D}"/usr/include INSTALL_MAN="${D}"/usr/share/man install-iwmulticall \
+                       || die "make install-iwmulticall failed"
+       fi
+
+       if use nls; then
+               for lang in fr cs; do
+                       for man in 5 7 8; do
+                               insinto /usr/share/man/${lang}/man${man}
+                               doins ${lang}/*.${man}
+                       done
+
+                       [[ -f README.${lang} ]] && dodoc README.${lang}
+               done
+       fi
+
+       dodoc CHANGELOG.h DISTRIBUTIONS.txt HOTPLUG.txt IFRENAME-VS-XXX.txt PCMCIA.txt README
+}