dev-util/cutter: version bump to 1.7.
authorTact Yoshida <otakuto.gentoo@gmail.com>
Sat, 18 Aug 2018 21:28:56 +0000 (06:28 +0900)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 19 Aug 2018 22:50:31 +0000 (00:50 +0200)
Package-Manager: Portage-2.3.44, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/9622

dev-util/cutter/Manifest
dev-util/cutter/cutter-1.7.ebuild [new file with mode: 0644]
dev-util/cutter/files/cutter-1.7-python3-config.patch [new file with mode: 0644]

index e13009f0b8b1d85555a0cf3c946cb8ee413b8188..3eaf10ed104a8635ee7558a06bb74f85bb9e863a 100644 (file)
@@ -1,3 +1,4 @@
 DIST cutter-1.0.tar.gz 614826 BLAKE2B 8f75343e57bf986d80dde3dc3ceb59675d28854744d8cc5fac783514e9c200595990d4860ee45db6544537d4f367df5b62a034e298bf273e44302edfa1647c84 SHA512 af6be59be7871d21d4f665e8ecb7f8224d99ccf7d62793e989ccd780ee521641c6ec0d941b46bb82770f5d44e5c0ef2efc29f9be303385e8e757e62a54bf53b1
 DIST cutter-1.4.tar.gz 1067162 BLAKE2B 2f7eceffcfb3c542695e03ec72de1c99451f8278e91f50abc2e87542efbd2cc73d5a52b0e5303b9cea751edf91bc71b63295edd5b32d1b2b9ed3a1443cfc92e7 SHA512 54caec67e57f2ff3908942c1ebd1e909c65204c6f31d0ec95e31f46e03364f309898006b93555ba81287c0d74faf407272226e5ec65b3148ecde8feec11ca3be
 DIST cutter-1.6.tar.gz 1083427 BLAKE2B d51b88f2b9dd2655ef58d7075086959ec3ed59ed4b21db81a792ee165deda523a4e59378c954d0f2aa5b0af25d67329ed2119c004edc402c9b593a3b230a6fd9 SHA512 83aaadfbaccdaa514606408868c050e22d0a80a749b98a9f6df929467a16e69b0d454b25ce1cf53e35ebbfb74e9b39e2bd390057488c9bb3992a442ca306c2f1
+DIST cutter-1.7.tar.gz 1099734 BLAKE2B 200621a902fabee66ebb6e02cc0efb7a705320c6071db5ce64adee0717977a72056bb5ef3ea8f8cad05488c7f031da7c24bbfc2986bb780f111f0a3a5b7a5b0e SHA512 52eea3017ebe02dee4f4e2f7109486ef2b833359959f7058fff49b4462dbc551e6d25cf31da934c9dc8489dad68ad2a3ba8b12fa60789852d13e8d3cb225a1b8
diff --git a/dev-util/cutter/cutter-1.7.ebuild b/dev-util/cutter/cutter-1.7.ebuild
new file mode 100644 (file)
index 0000000..283bd48
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils xdg-utils gnome2-utils
+
+DESCRIPTION="A Qt and C++ GUI for radare2 reverse engineering framework"
+HOMEPAGE="https://www.radare.org"
+SRC_URI="https://github.com/radareorg/cutter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jupyter webengine"
+REQUIRED_USE="webengine? ( jupyter )"
+
+DEPEND="
+       >=dev-qt/qtcore-5.9.1:5
+       >=dev-qt/qtgui-5.9.1:5
+       >=dev-qt/qtsvg-5.9.1:5
+       >=dev-qt/qtwidgets-5.9.1:5
+       >=dev-util/radare2-2.7.0
+       jupyter? ( dev-python/jupyter )
+       webengine? ( >=dev-qt/qtwebengine-5.9.1:5[widgets] )
+"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+       "${FILESDIR}/${P}-python3-config.patch"
+)
+
+src_configure() {
+       local myqmakeargs=(
+               CUTTER_ENABLE_JUPYTER=$(usex jupyter true false)
+               CUTTER_ENABLE_QTWEBENGINE=$(usex webengine true false)
+               PREFIX=\'${EPREFIX}/usr\'
+       )
+
+       eqmake5 "${myqmakeargs[@]}" src
+}
+
+src_install() {
+       emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+}
diff --git a/dev-util/cutter/files/cutter-1.7-python3-config.patch b/dev-util/cutter/files/cutter-1.7-python3-config.patch
new file mode 100644 (file)
index 0000000..51a811d
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/Cutter.pro   2018-04-24 17:43:11.000000000 +0900
++++ b/src/Cutter.pro   2018-07-08 21:21:34.280748499 +0900
+@@ -74,11 +74,13 @@
+         LIBS += -F$$PYTHON_FRAMEWORK_DIR -framework Python
+         DEFINES += MACOS_PYTHON_FRAMEWORK_BUNDLED
+     } else {
+-        CONFIG += link_pkgconfig
+-        !packagesExist(python3) {
+-            error("ERROR: Python 3 could not be found. Make sure it is available to pkg-config.")
++        system(type python3-config) {
++            LIBS += $$system(python3-config --libs)
++            TMP = $$system(python3-config --includes)
++            INCLUDEPATH += $$replace(TMP, "-I", "")
++        } else {
++            error("ERROR: Python 3 could not be found. Make sure it is available to python3-config.")
+         }
+-        PKGCONFIG += python3
+     }
+ }
+