media-plugins/vdr-dvbapi: fixed depend for vdr-2.4.1
authorJoerg Bornkessel <hd_brummy@gentoo.org>
Fri, 27 Dec 2019 19:14:19 +0000 (20:14 +0100)
committerJoerg Bornkessel <hd_brummy@gentoo.org>
Fri, 27 Dec 2019 19:15:41 +0000 (20:15 +0100)
cleanup old
vdr-dvbapi-2.2.5 need vdr-2.4.x

Suggested-by: Martin Dummer <martin.dummer@gmx.net>
Bug: https://bugs.gentoo.org/703898
Closes: https://bugs.gentoo.org/703898
Package-Manager: Portage-2.3.83, Repoman-2.3.18
Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
media-plugins/vdr-dvbapi/Manifest
media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild [deleted file]
media-plugins/vdr-dvbapi/vdr-dvbapi-2.2.2.ebuild [deleted file]
media-plugins/vdr-dvbapi/vdr-dvbapi-2.2.5.ebuild

index cba8d0ff97ab338d90aa6eadaaf2d309ec849cc0..5eda0bbb5d930af1d13cec1ee25b8cdc3128b60b 100644 (file)
@@ -1,4 +1,2 @@
-DIST vdr-dvbapi-2.1.1.tar.gz 82813 BLAKE2B 2dd2b4aa11a645b4168ebbae962371f94a6e70ff905b06230048a69921f31521468506f2959ce5d5327b4cf61edc620686210520239e751e142e524751640e0d SHA512 fb632e66c9e477663eb1edf5e630a20b2165495c89d5bd6294d74d6a28c8386021d90914c9c6b958ea3c5c1d0958cc69efa5c65ef72c510c224d676f1eca39ae
-DIST vdr-dvbapi-2.2.2.tar.gz 83995 BLAKE2B 6ddd9cc4e3edbd504505b7bbb9c40e203d53faab43b3d1afe9b9834cf3d751ba469536b5f27c24cfb04afeba1378ee3ac8dc0885db8a4576ce7a275233c88ca6 SHA512 01d3a6368e0233a7b96b6ea57b28884a004a130d63da2b2958b1616a1108e83389b68cbe32ec7fc6be65d6741912c4f46621b659fb13dba56e594a1a18af2c63
 DIST vdr-plugin-dvbapi-2.2.4.tar.gz 94419 BLAKE2B 326346b418ece22674aa0d84efd798a9eb8e958586d24385b4e468c11478f63ed89e94c742c57c5b1e955dc598db29a39e3730d71c93005aa6dcda262545e4e2 SHA512 d1313e927978fcf150ae14e570c16059caeeec07992066b03282295147872da3bdb191209408539c2a70c2ada868f731e9e5504a8dd737143f86e33a85fdf0c7
 DIST vdr-plugin-dvbapi-2.2.5.tar.gz 95270 BLAKE2B dbab07bc7df8fdc7ec009b82723631a5e61cb1d4a9afdad16e32282a3e71d6bc87e7c78ec8cea73690606bda504c19bdd9123d1ca7a4e712b15ca884c77dabaa SHA512 7036705ddf706192774f511cab813c64d092a1db1c635003e28d6960d3d46ef484f44b86c15fae782d29ada728eae1861d009d91cb71ad77cb0a1b2ad316069b
diff --git a/media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild b/media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild
deleted file mode 100644 (file)
index 78e7760..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit vdr-plugin-2
-
-DESCRIPTION="VDR Plugin: allows connect VDR to OScam"
-HOMEPAGE="https://github.com/manio/vdr-plugin-dvbapi"
-SRC_URI="https://github.com/manio/vdr-plugin-dvbapi/archive/v${PV}.tar.gz -> vdr-dvbapi-${PV}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2"
-
-DEPEND=">=media-video/vdr-2.1.4"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/vdr-plugin-dvbapi-${PV}"
-
-src_prepare() {
-       vdr-plugin-2_src_prepare
-
-       # respect the system CXXFLAGS
-       sed -e "s:FLAGS:CXXFLAGS:" -i FFdecsa/Makefile
-
-       # Prepare flags for FFdeCSA
-       if [ -n "${VDR_DVBAPI_PARALLEL}" ]; then
-               PARALLEL="${VDR_DVBAPI_PARALLEL}"
-       else
-               # [32/64] Core2 (SSSE3) achieves best results with SSE2 & SSE
-               # [64] Athlon64 (SSE2) does much better with 64_LONG
-               # [32] Athlon64 (SSE2) does best with MMX
-               # [32] Pentium4 & Atom (SSE2) work best with SSE2 & SSE
-               # [32] AthlonXP (SSE) has MMX faster
-
-               # To avoid parsing -march=, we use ugly assumption that Intels don't
-               # have 3dnow and AMDs do. SSE achieves good results only on Intel CPUs,
-               # and LONG is best on 64-bit AMD CPUs.
-
-               if ! use cpu_flags_x86_3dnow && use cpu_flags_x86_sse2; then
-                       PARALLEL=PARALLEL_128_SSE2
-               elif ! use cpu_flags_x86_3dnow && use cpu_flags_x86_sse; then
-                       PARALLEL=PARALLEL_128_SSE
-               elif use amd64; then
-                       PARALLEL=PARALLEL_64_LONG
-               elif use cpu_flags_x86_mmx; then
-                       PARALLEL=PARALLEL_64_MMX
-               else
-               # fallback values:
-               # PARALLEL_32_INT fails with gcc4.4 on x86&amd64
-               # PARALLEL_64_2INT fails with gcc4.4 on x86
-               # PARALLEL_128_4INT seems to be the fastest non-failing fallback
-                       PARALLEL=PARALLEL_128_4INT
-               fi
-
-               ewarn "VDR_DVBAPI_PARALLEL in your system make.conf is not set, guessing value from USEflags (${PARALLEL})."
-               ewarn "This setting may be suboptimal, so you'll probably want to tweak it yourself."
-               ewarn "\n\tRun the script ${WORKDIR}/extra/FFdecsa-benchmark.sh"
-               ewarn "\tand add the output parameter from  PARALLEL= to your system make.conf"
-               ewarn "\tVDR_DVBAPI_PARALLEL= your parameter"
-       fi
-
-       export PARALLEL
-}
-
-pkg_postinst() {
-       vdr-plugin-2_pkg_postinst
-
-       elog "This software might be illegal in some countries or violate"
-       elog "rules of your DVB provider"
-       elog "Please respect these rules.\n"
-
-       elog "We do not offer support of any kind"
-       elog "Asking for keys or for installation help will be ignored by gentoo developers!\n"
-}
diff --git a/media-plugins/vdr-dvbapi/vdr-dvbapi-2.2.2.ebuild b/media-plugins/vdr-dvbapi/vdr-dvbapi-2.2.2.ebuild
deleted file mode 100644 (file)
index 58a6b05..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vdr-plugin-2
-
-DESCRIPTION="VDR Plugin: allows connect VDR to OScam"
-HOMEPAGE="https://github.com/manio/vdr-plugin-dvbapi"
-SRC_URI="https://github.com/manio/vdr-plugin-dvbapi/archive/v${PV}.tar.gz -> vdr-dvbapi-${PV}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2"
-
-DEPEND=">=media-video/vdr-2.1.4"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/vdr-plugin-dvbapi-${PV}"
-
-DOCS="HISTORY INSTALL README FFdecsa/docs"
-
-src_prepare() {
-       vdr-plugin-2_src_prepare
-
-       # respect the system CXXFLAGS
-       sed -e "s:FLAGS:CXXFLAGS:" -i FFdecsa/Makefile
-
-       # Prepare flags for FFdeCSA
-       if [ -n "${VDR_DVBAPI_PARALLEL}" ]; then
-               PARALLEL="${VDR_DVBAPI_PARALLEL}"
-       else
-               # [32/64] Core2 (SSSE3) achieves best results with SSE2 & SSE
-               # [64] Athlon64 (SSE2) does much better with 64_LONG
-               # [32] Athlon64 (SSE2) does best with MMX
-               # [32] Pentium4 & Atom (SSE2) work best with SSE2 & SSE
-               # [32] AthlonXP (SSE) has MMX faster
-
-               # To avoid parsing -march=, we use ugly assumption that Intels don't
-               # have 3dnow and AMDs do. SSE achieves good results only on Intel CPUs,
-               # and LONG is best on 64-bit AMD CPUs.
-
-               if ! use cpu_flags_x86_3dnow && use cpu_flags_x86_sse2; then
-                       PARALLEL=PARALLEL_128_SSE2
-               elif ! use cpu_flags_x86_3dnow && use cpu_flags_x86_sse; then
-                       PARALLEL=PARALLEL_128_SSE
-               elif use amd64; then
-                       PARALLEL=PARALLEL_64_LONG
-               elif use cpu_flags_x86_mmx; then
-                       PARALLEL=PARALLEL_64_MMX
-               else
-               # fallback values:
-               # PARALLEL_32_INT fails with gcc4.4 on x86&amd64
-               # PARALLEL_64_2INT fails with gcc4.4 on x86
-               # PARALLEL_128_4INT seems to be the fastest non-failing fallback
-                       PARALLEL=PARALLEL_128_4INT
-               fi
-
-               ewarn "VDR_DVBAPI_PARALLEL in your system make.conf is not set, guessing value from USEflags (${PARALLEL})."
-               ewarn "This setting may be suboptimal, so you'll probably want to tweak it yourself."
-               ewarn "\n\tRun the script ${WORKDIR}/extra/FFdecsa-benchmark.sh"
-               ewarn "\tand add the output parameter from  PARALLEL= to your system make.conf"
-               ewarn "\tVDR_DVBAPI_PARALLEL= your parameter"
-       fi
-
-       export PARALLEL
-}
-
-pkg_postinst() {
-       vdr-plugin-2_pkg_postinst
-
-       elog "This software might be illegal in some countries or violate"
-       elog "rules of your DVB provider"
-       elog "Please respect these rules.\n"
-
-       elog "We do not offer support of any kind"
-       elog "Asking for keys or for installation help will be ignored by gentoo developers!\n"
-}
index 975b899864a2e68351147f4cb6fe54d17bb58244..226f7268108c8c87b45726463894b4b8f9e53d5e 100644 (file)
@@ -16,7 +16,7 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 dvbcsa"
 
-DEPEND=">=media-video/vdr-2.1.4
+DEPEND=">=media-video/vdr-2.4.1
        dvbcsa? ( media-libs/libdvbcsa )"
 RDEPEND="${DEPEND}"