app-shells/thefuck: bump to 3.28
authorAndrew Attali <me@aphypnise.eu>
Tue, 8 Jan 2019 09:41:22 +0000 (10:41 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 19 Jan 2019 03:34:53 +0000 (04:34 +0100)
Also added python 3.7 as supported version.
Taked over the proxy maint as requested by the former.

Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Andrew Attali <me@aphypnise.eu>
Closes: https://github.com/gentoo/gentoo/pull/10775
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-shells/thefuck/Manifest
app-shells/thefuck/metadata.xml
app-shells/thefuck/thefuck-3.28.ebuild [new file with mode: 0644]

index 307d8b12f5bcf64feb28f6e9a568f61b081277ae..c41029c3faa2aa2a00104ca5c9d59664c2d7c67d 100644 (file)
@@ -1 +1,2 @@
 DIST thefuck-3.27.tar.gz 1367120 BLAKE2B a840ac3e8f6807df632948e2fe2789a47bdcfececfd4a9bb0f1836bbaa641501e13c559221b9a2f25bbd93505c8b03db102636e480ece116a42c46f341d5cd35 SHA512 766c589f0e99a9773e74094e91c6a74d00e5be8b7241680ad664ecc3f549b597416bc7a4d289f399ed3a0d9ccad629ed78bb983edc809664c303c687ea1eec1a
+DIST thefuck-3.28.tar.gz 1369230 BLAKE2B 0825ead15eae174b08bc2608ff64e1cd5993484a8aa6cc5cd1f6dbb3a856898e7c77eb9d5f92884f01261cf5cc5b00696c6e706a6553ce661866689e3d94d746 SHA512 6c3edcfff604567a18209bf46aceb662ed4549efd0e3b0daee1abee8a93fbe3ff4dfa260eb74c3d560b3a798e3cc90f911072d694a0d986a09c8581e951421d2
index e02f8f7384b6b1302b4beb34347d9b46cbba3565..302e34ce061b39bf23833cf1193a37104e897429 100644 (file)
@@ -2,8 +2,8 @@
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
        <maintainer type="person">
-               <email>holgersson@posteo.de</email>
-               <name>Nils Freydank</name>
+               <email>me@aphypnise.eu</email>
+               <name>Andrew Attali</name>
        </maintainer>
        <maintainer type="project">
                <email>proxy-maint@gentoo.org</email>
diff --git a/app-shells/thefuck/thefuck-3.28.ebuild b/app-shells/thefuck/thefuck-3.28.ebuild
new file mode 100644 (file)
index 0000000..4cd6c3c
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       dev-python/psutil[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/decorator[${PYTHON_USEDEP}]
+       dev-python/colorama[${PYTHON_USEDEP}]
+       dev-python/pyte[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-mock[${PYTHON_USEDEP}]
+       )"
+
+python_prepare_all() {
+       sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       py.test -vv || die
+}