dev-python/tox: Bump to 3.14.2
authorMichał Górny <mgorny@gentoo.org>
Tue, 3 Dec 2019 07:30:59 +0000 (08:30 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 3 Dec 2019 09:47:23 +0000 (10:47 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/tox/Manifest
dev-python/tox/tox-3.14.2.ebuild [new file with mode: 0644]

index fabd97c6e2ceb5d4ab87a1193c015bf772f73cd5..7761ac803ab1919479881936960eda49af6c2d84 100644 (file)
@@ -1,4 +1,5 @@
 DIST tox-2.9.1.tar.gz 1855982 BLAKE2B 3e2f5fd3d3e45e54f96b0a6fc8f9e98bfba3b48540cc2922a897e016b5aabc9974772c9b897e0fab7b38b00f99478a063ad988ffa8b65fa53f684997334e492c SHA512 ff19b2bb7ac963379f1cccd4973ad9eb4dabfbda976cde7caba50ad010d8fa57c1cba91d63e3e0512e44cc7d350bc9270fbd9b30db1bd55f7d9c239e7623d066
 DIST tox-3.12.1.tar.gz 283964 BLAKE2B b7cb2394a721f281552d1f614a6059f7025390a4ea03fd970c85330dffb97f601f0c3f8c9c9b05f86b5b92e87ef80fba48676201550581562b8cf3f1b2afa34b SHA512 d7ed7ce17b03b5c8e3ba95e14f547c8dbb9a04ac38b98fb24c09261b5087ffc83b05e9a03607fa53ce61340a3ba69fc4121622f7fe338ce8ed402d25d59c7e6a
 DIST tox-3.13.2.tar.gz 286403 BLAKE2B 579692b4902e9cff0ede954fcf2d1a7f1771c0e3ad4b6cd362f93b1e745b238c739ab857b2394700d736eb6a0d91c1f2b385de1926908c0c4aa5a9d183a6b29a SHA512 b2447d4300a7469eb53f094427a7bb92ac973b5fdcfdf9b98736225b3a315953e06e92a4accb2f84f8649fe79a9146fb804afdf9adebf9231afb0bd143e646cc
+DIST tox-3.14.2.tar.gz 288615 BLAKE2B d74de145c8e839938c332f1e5a4819126d2ab1212679cc5c50390a9c7b0edb8a7059c55d9c6c8d3697f36cace7c0d3361725f5020d3f9d7efcddf8faae8c9be5 SHA512 c573d4b6a8e6538eb17031f7432d6f52f75514309c5daad53286aeff00db51146a5de089bdc1efd76f8126c374efa02c0ea7a8ca4224c0ec0f9ee945edd62c97
 DIST tox-3.2.1.tar.gz 268827 BLAKE2B 764835d04fb0c17f32eb8e2041b83f90d6a729b781a5b5b95e9ecb1162f1c29ed595d4a6369524b390a31853b8003485b27a3a12d63e84f49e92675f1a9bee13 SHA512 79f5a1c8f6e818fbb8444754e3767d880fc1fdfe63b46c518d37440fe2b2f3ce572865aff83d9492c24486fded49893cc31bd9b11254bac4db507260304bc76f
diff --git a/dev-python/tox/tox-3.14.2.ebuild b/dev-python/tox/tox-3.14.2.ebuild
new file mode 100644 (file)
index 0000000..525bdb4
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~sparc ~x86"
+
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/filelock[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
+       ' python3_{5,6,7} pypy3)
+       dev-python/packaging[${PYTHON_USEDEP}]
+       <dev-python/pluggy-1.0[${PYTHON_USEDEP}]
+       dev-python/pip[${PYTHON_USEDEP}]
+       dev-python/py[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/toml[${PYTHON_USEDEP}]
+       >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
+# TODO: figure out how to make tests work without the package being
+# installed first.
+BDEPEND="
+       test? (
+               ${RDEPEND}
+               >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+               <dev-python/flaky-4
+               >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+               dev-python/pathlib2[${PYTHON_USEDEP}]
+               >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+               <dev-python/pytest-mock-2.0[${PYTHON_USEDEP}]
+               =dev-python/tox-${PV}[${PYTHON_USEDEP}]
+       )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-3.9.0-strip-setuptools_scm.patch"
+)
+
+src_prepare() {
+       distutils-r1_src_prepare
+
+       # broken without internet
+       sed -i -e 's:test_provision_non_canonical_dep:_&:' \
+               tests/unit/session/test_provision.py || die
+       sed -i -e 's:test_provision_interrupt_child:_&:' \
+               tests/integration/test_provision_int.py || die
+       # broken with our mock version (?)
+       sed -i -e 's:test_create_KeyboardInterrupt:_&:' \
+               tests/unit/test_venv.py || die
+       # broken with Gentoo Python layout
+       sed -i -e 's:test_tox_get_python_executable:_&:' \
+               -e 's:test_find_alias_on_path:_&:' \
+               tests/unit/interpreters/test_interpreters.py || die
+}
+
+python_test() {
+       distutils_install_for_testing
+       pytest -vv --no-network || die "Testsuite failed under ${EPYTHON}"
+}