dev-python/m2crypto: Replace virts with cond deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:16:44 +0000 (22:16 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:17:55 +0000 (22:17 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/m2crypto/m2crypto-0.31.0-r2.ebuild
dev-python/m2crypto/m2crypto-0.35.2.ebuild

index cf7277f442e7f0f328017179aee88ebcdc5cc5eb..56d88a04bbae6b36299cd63a237c78948cbae09f 100644 (file)
@@ -23,7 +23,9 @@ IUSE="libressl"
 RDEPEND="
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:0= )
-       virtual/python-typing[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/typing[${PYTHON_USEDEP}]
+       ' -2)
 "
 DEPEND="${RDEPEND}"
 BDEPEND="
index 81681dbea8575193953b875beff236221ba0df53..691ce76063c71032547c7f7a86589f3f2a8332a2 100644 (file)
@@ -21,7 +21,9 @@ IUSE="libressl"
 RDEPEND="
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:0= )
-       virtual/python-typing[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/typing[${PYTHON_USEDEP}]
+       ' -2)
 "
 DEPEND="${RDEPEND}"
 BDEPEND="