projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5145d31
)
dev-libs/libyaml: fix doc build support
author
Tim Harder
<radhermit@gentoo.org>
Sat, 11 May 2019 05:41:44 +0000
(
00:41
-0500)
committer
Tim Harder
<radhermit@gentoo.org>
Sat, 11 May 2019 05:50:44 +0000
(
00:50
-0500)
Also, stop installing example code.
Closes: https://bugs.gentoo.org/685594
Signed-off-by: Tim Harder <radhermit@gentoo.org>
dev-libs/libyaml/libyaml-0.2.2.ebuild
patch
|
blob
|
history
diff --git
a/dev-libs/libyaml/libyaml-0.2.2.ebuild
b/dev-libs/libyaml/libyaml-0.2.2.ebuild
index b6373be87d00379f915adf4117d9f8d1e660d601..84ef179965584162bec92b32ccb0f19d1add4148 100644
(file)
--- a/
dev-libs/libyaml/libyaml-0.2.2.ebuild
+++ b/
dev-libs/libyaml/libyaml-0.2.2.ebuild
@@
-32,13
+32,13
@@
src_configure() {
econf $(use_enable static-libs static)
}
+src_compile() {
+ emake
+ use doc && emake html
+}
+
src_install() {
use doc && HTML_DOCS=( doc/html/. )
default
-
find "${D}" -name '*.la' -delete || die
-
- docinto examples
- dodoc tests/example-*.c
- docompress -x /usr/share/doc/${PF}/examples
}