dev-python/matplotlib-python2: Split from matplotlib
authorMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 19:05:23 +0000 (20:05 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 20:40:20 +0000 (21:40 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/matplotlib-python2/Manifest [new file with mode: 0644]
dev-python/matplotlib-python2/files/matplotlib-2.2.4-doc-fix.patch [new file with mode: 0644]
dev-python/matplotlib-python2/files/matplotlib-2.2.4-no-jqueryui-download.patch [new file with mode: 0644]
dev-python/matplotlib-python2/matplotlib-python2-2.2.4.ebuild [new file with mode: 0644]
dev-python/matplotlib-python2/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/matplotlib-python2/Manifest b/dev-python/matplotlib-python2/Manifest
new file mode 100644 (file)
index 0000000..0f0b904
--- /dev/null
@@ -0,0 +1 @@
+DIST matplotlib-2.2.4.tar.gz 36974286 BLAKE2B 9c4c69163a23ff02107ee155f72e142dcf31ba965f6a20f468b96f3f4b70b95ff6caade6b14bcbacd5b231848d2000ce6af9f113feefb41d6e186725349490d3 SHA512 968f5731b8a9a2c5575403c60d5b0a98a452b33094e520be44f4d901f892d082babc8fc1d73c519e1ff2baf756f3cb7652f4b796e166d66dfda31f7e50c58139
diff --git a/dev-python/matplotlib-python2/files/matplotlib-2.2.4-doc-fix.patch b/dev-python/matplotlib-python2/files/matplotlib-2.2.4-doc-fix.patch
new file mode 100644 (file)
index 0000000..b6a01b0
--- /dev/null
@@ -0,0 +1,18 @@
+diff --git a/doc/conf.py b/doc/conf.py
+index 017ce210e..5a397082b 100644
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -170,10 +170,10 @@ source_encoding = "utf-8"
+ master_doc = 'contents'
+ # General substitutions.
+-from matplotlib.compat.subprocess import check_output
+-SHA = check_output(['git', 'describe', '--dirty']).decode('utf-8').strip()
++#from matplotlib.compat.subprocess import check_output
++#SHA = check_output(['git', 'describe', '--dirty']).decode('utf-8').strip()
+-html_context = {'sha': SHA}
++#html_context = {'sha': SHA}
+ project = 'Matplotlib'
+ copyright = ('2002 - 2012 John Hunter, Darren Dale, Eric Firing, '
diff --git a/dev-python/matplotlib-python2/files/matplotlib-2.2.4-no-jqueryui-download.patch b/dev-python/matplotlib-python2/files/matplotlib-2.2.4-no-jqueryui-download.patch
new file mode 100644 (file)
index 0000000..9d13adb
--- /dev/null
@@ -0,0 +1,18 @@
+diff --git a/setup.py b/setup.py
+index 41037e95d..6a438fa99 100644
+--- a/setup.py
++++ b/setup.py
+@@ -178,9 +178,10 @@ class sdist_with_jquery(_orgin_sdist):
+ class install_lib_with_jquery(InstallLibCommand):
+     def run(self):
+         InstallLibCommand.run(self)
+-        _download_jquery_to(
+-            os.path.join(self.install_dir, "matplotlib/backends/web_backend/"))
+-
++        # Avoid downloading jquery ui during emerge: we already have it in
++        # pypi's tarball. use this!
++        name = "matplotlib/backends/web_backend/jquery-ui-1.12.1"
++        os.rename(os.path.join('lib', name), os.path.join(self.install_dir, name))
+ class develop_with_jquery(DevelopCommand):
+     def run(self):
diff --git a/dev-python/matplotlib-python2/matplotlib-python2-2.2.4.ebuild b/dev-python/matplotlib-python2/matplotlib-python2-2.2.4.ebuild
new file mode 100644 (file)
index 0000000..3f9831c
--- /dev/null
@@ -0,0 +1,216 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
+
+MY_PN=${PN/-python2}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Pure python plotting library with matlab like syntax (py2 version)"
+HOMEPAGE="https://matplotlib.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+# Main license: matplotlib
+# Some modules: BSD
+# matplotlib/backends/qt4_editor: MIT
+# Fonts: BitstreamVera, OFL-1.1
+LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="cairo excel gtk2 gtk3 latex qt5 test tk wxwidgets"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+       test? (
+               cairo latex qt5 tk wxwidgets
+               || ( gtk2 gtk3 )
+               )"
+
+# #456704 -- a lot of py2-only deps
+COMMON_DEPEND="
+       dev-python/functools32[${PYTHON_USEDEP}]
+       dev-python/subprocess32[${PYTHON_USEDEP}]
+       dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
+       dev-python/cycler[${PYTHON_USEDEP}]
+       || (
+               >=dev-python/numpy-python2-1.7.1[${PYTHON_USEDEP}]
+               >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+       )
+       dev-python/python-dateutil:0[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10[${PYTHON_USEDEP}]
+       media-fonts/stix-fonts
+       media-libs/freetype:2
+       media-libs/libpng:0
+       >=media-libs/qhull-2013
+       >=dev-python/kiwisolver-1.0.0[${PYTHON_USEDEP}]
+       cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
+       gtk2? (
+               dev-libs/glib:2=
+               x11-libs/gdk-pixbuf
+               x11-libs/gtk+:2
+               dev-python/pygtk[${PYTHON_USEDEP}] )
+       wxwidgets? ( >=dev-python/wxpython-2.8:*[${PYTHON_USEDEP}] )"
+
+# internal copy of pycxx highly patched
+#      dev-python/pycxx
+
+DEPEND="${COMMON_DEPEND}
+       dev-python/versioneer[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       virtual/pkgconfig
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
+               )"
+
+RDEPEND="${COMMON_DEPEND}
+       !<dev-python/matplotlib-3
+       >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
+       excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
+       gtk3? (
+               dev-python/pygobject:3[${PYTHON_USEDEP}]
+               x11-libs/gtk+:3[introspection] )
+       latex? (
+               virtual/latex-base
+               app-text/ghostscript-gpl
+               app-text/dvipng
+               app-text/poppler[utils]
+               dev-texlive/texlive-fontsrecommended
+               dev-texlive/texlive-latexextra
+               dev-texlive/texlive-xetex
+       )
+       qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )"
+
+# A few C++ source files are written to srcdir.
+# Other than that, the ebuild shall be fit for out-of-source build.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+pkg_setup() {
+       unset DISPLAY # bug #278524
+}
+
+use_setup() {
+       local uword="${2:-${1}}"
+       if use ${1}; then
+               echo "${uword} = True"
+               echo "${uword}agg = True"
+       else
+               echo "${uword} = False"
+               echo "${uword}agg = False"
+       fi
+}
+
+python_prepare_all() {
+# Generates test failures, but fedora does it
+#      local PATCHES=(
+#              "${FILESDIR}"/${P}-unbundle-pycxx.patch
+#              "${FILESDIR}"/${P}-unbundle-agg.patch
+#      )
+#      rm -r agg24 CXX || die
+#      rm -r agg24 || die
+
+#      cat > lib/${PN}/externals/six.py <<-EOF
+#      from __future__ import absolute_import
+#      from six import *
+#      EOF
+
+       local PATCHES=(
+               "${FILESDIR}"/${MY_PN}-2.2.4-doc-fix.patch
+               "${FILESDIR}"/${MY_PN}-2.2.4-no-jqueryui-download.patch
+       )
+
+       sed \
+               -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
+               -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
+               || die "sed pyparsing failed"
+
+       hprefixify setupext.py
+
+       export XDG_RUNTIME_DIR="${T}/runtime-dir"
+       mkdir "${XDG_RUNTIME_DIR}" || die
+       chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+       append-flags -fno-strict-aliasing
+       append-cppflags -DNDEBUG  # or get old trying to do triangulation
+       tc-export PKG_CONFIG
+}
+
+python_configure() {
+       mkdir -p "${BUILD_DIR}" || die
+
+       # create setup.cfg (see setup.cfg.template for any changes).
+
+       # common switches.
+       cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
+               [directories]
+               basedirlist = ${EPREFIX}/usr
+               [provide_packages]
+               pytz = False
+               dateutil = False
+               [packages]
+               tests = $(usex test True False)
+               [gui_support]
+               agg = True
+               pyside = False
+               pysideagg = False
+               qt4 = False
+               qt4agg = False
+               $(use_setup cairo)
+               $(use_setup gtk3)
+               $(use_setup qt5)
+               $(use_setup tk)
+       EOF
+
+       if use gtk3 && use cairo; then
+               echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
+       else
+               echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
+       fi
+
+       cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
+               $(use_setup gtk2 gtk)
+               $(use_setup wxwidgets wx)
+       EOF
+}
+
+wrap_setup() {
+       local MAKEOPTS=-j1
+       local -x MPLSETUPCFG="${BUILD_DIR}"/setup.cfg
+       unset DISPLAY
+       "$@"
+}
+
+python_compile() {
+       wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
+}
+
+python_test() {
+       wrap_setup distutils_install_for_testing
+
+       virtx "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)"
+}
+
+python_install() {
+       wrap_setup distutils-r1_python_install
+
+       # mpl_toolkits namespace
+       python_moduleinto mpl_toolkits
+       python_domodule lib/mpl_toolkits/__init__.py
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       find "${D}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/matplotlib-python2/metadata.xml b/dev-python/matplotlib-python2/metadata.xml
new file mode 100644 (file)
index 0000000..d238bed
--- /dev/null
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>sci@gentoo.org</email>
+               <name>Gentoo Science Project</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+               <name>Python</name>
+       </maintainer>
+       <longdescription lang="en">
+       matplotlib is an interactive library for plotting and doing basic
+       data analysis in python with a syntax similar to matlab. It provides a
+       variety of backends and hard copy formats for almost ready
+       publication plots.
+       </longdescription>
+       <use>
+               <flag name="excel">Pull <pkg>dev-python/xlwt</pkg> for the exceltools toolkit</flag>
+               <flag name="gtk2">Enable <pkg>x11-libs/gtk+</pkg>:2 support</flag>
+               <flag name="gtk3">Enable <pkg>x11-libs/gtk+</pkg>:3 support</flag>
+       </use>
+       <upstream>
+               <remote-id type="pypi">matplotlib</remote-id>
+               <remote-id type="sourceforge">matplotlib</remote-id>
+       </upstream>
+</pkgmetadata>