1.7.2 version bump, remove old ebuilds. Note that this does not fix the SANE problem.
authorMarcelo Góes <vanquirius@gentoo.org>
Sat, 3 Mar 2007 17:01:58 +0000 (17:01 +0000)
committerMarcelo Góes <vanquirius@gentoo.org>
Sat, 3 Mar 2007 17:01:58 +0000 (17:01 +0000)
Package-Manager: portage-2.1.1-r2

net-print/hplip/ChangeLog
net-print/hplip/files/digest-hplip-1.7.2 [new file with mode: 0644]
net-print/hplip/hplip-1.7.2.ebuild [new file with mode: 0644]

index e5d30a70edadf90977912a3d4b6eb403074f5cbf..4e7e5f0c26461c835bf43cd6430683dc9b8df7ec 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for net-print/hplip
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.50 2007/02/26 12:17:35 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.51 2007/03/03 17:01:58 vanquirius Exp $
+
+*hplip-1.7.2 (03 Mar 2007)
+
+  03 Mar 2007; Marcelo Goes <vanquirius@gentoo.org>
+  -files/hplip-1.7.1-1.patch, -hplip-1.6.12.ebuild, -hplip-1.7.1.ebuild,
+  +hplip-1.7.2.ebuild:
+  1.7.2 version bump, remove old ebuilds. Note that this does not fix the SANE
+  problem.
 
   26 Feb 2007; Christian Faulhammer <opfer@gentoo.org> hplip-1.6.10.ebuild:
   stable x86; bug 158911
diff --git a/net-print/hplip/files/digest-hplip-1.7.2 b/net-print/hplip/files/digest-hplip-1.7.2
new file mode 100644 (file)
index 0000000..5a4d525
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 1c4b65222333d048450d37082d521b1e foomatic-db-hpijs-20060720.tar.gz 98252
+RMD160 0c2c09f3cea6fc2a8e5da216bd9996b96d91613d foomatic-db-hpijs-20060720.tar.gz 98252
+SHA256 1e50f603b46b1d07980212b2e5dfc5d72d07c889259e79ecbf09469fef5ad20e foomatic-db-hpijs-20060720.tar.gz 98252
+MD5 739a9cef41ca655ad98bc35a39c0517e hplip-1.7.2.tar.gz 11092344
+RMD160 04a9c60c76d61e8e425346811df664d04d375acd hplip-1.7.2.tar.gz 11092344
+SHA256 f303d304483cff1d4939b2dafdf5d6625101444bc51362c10b2743e5179b02d3 hplip-1.7.2.tar.gz 11092344
diff --git a/net-print/hplip/hplip-1.7.2.ebuild b/net-print/hplip/hplip-1.7.2.ebuild
new file mode 100644 (file)
index 0000000..efa71a4
--- /dev/null
@@ -0,0 +1,116 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-1.7.2.ebuild,v 1.1 2007/03/03 17:01:58 vanquirius Exp $
+
+inherit eutils
+
+DB_V=20060720
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hplip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+       foomaticdb? (
+               http://gentooexperimental.org/~genstef/dist/foomatic-db-hpijs-${DB_V}.tar.gz
+               http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz
+       )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="foomaticdb snmp X qt3 ppds scanner"
+
+DEPEND=">=dev-lang/python-2.2.0
+       snmp? ( >=net-analyzer/net-snmp-5.0.9 )
+       !net-print/hpijs
+       !net-print/hpoj
+       virtual/ghostscript
+       scanner? (
+               >=media-gfx/sane-backends-1.0.9
+               || (
+                       X? ( >=media-gfx/xsane-0.89 )
+                       >=media-gfx/sane-frontends-1.0.9
+               )
+       )
+       qt3? ( >=dev-python/PyQt-3.11 =x11-libs/qt-3* )
+       >=dev-libs/libusb-0.1.10a
+       sys-apps/hotplug-base
+       net-print/cups
+       foomaticdb? ( net-print/foomatic-db-engine )
+       >=net-print/foomatic-filters-3.0.2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+       # avoid collisions with cups-1.2 compat symlinks
+       if [ -e ${ROOT}/usr/lib/cups/backend/hp ] && [ -e ${ROOT}/usr/libexec/cups/backend/hp ]; then
+               rm -f ${ROOT}/usr/libexec/cups/backend/hp{,fax};
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       # bug 98428
+       sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" \
+               hpssd.py
+}
+src_compile() {
+       econf \
+               $(use_enable snmp network-build) \
+               $(use_enable cups cups-install) \
+               $(use_enable ppds foomatic-install) \
+               || die "econf failed"
+       emake || die "emake failed"
+
+       if use foomaticdb ; then
+               cd ../foomatic-db-hpijs-${DB_V}
+               econf || die "econf failed"
+               rm -fR data-generators/hpijs-rss
+               emake || die "emake failed"
+       fi
+}
+
+
+src_install() {
+       # cups-1.2 installation paths, make sure that the .desktop is installed
+       sed -i -e "s:/usr/lib/cups:$(cups-config --serverbin):" \
+               -e 's:\(ICON_FILE = \).*:\1hplip.desktop:' \
+               -e 's:\(ICON_PATH = \).*:\1/usr/share/applications:' \
+               Makefile
+
+       emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+       newinitd "${FILESDIR}"/hplip.init.d hplip
+
+       if use scanner; then
+               dodir /usr/$(get_libdir)/sane
+               for i in libsane-hpaio.{la,so{,.1{,.0.0}}}; do
+                       dosym /usr/$(get_libdir)/${i} /usr/$(get_libdir)/sane/${i}; done
+       else
+               rm -f "${D}"/usr/$(get_libdir)/libsane-hpaio.{la,so{,.1{,.0.0}}}
+               rm -f "${D}"/etc/sane.d/dll.conf
+       fi
+
+       # bug 106035
+       if ! use qt3 ; then
+               rm -f "${D}"/usr/{bin/hp-,share/hplip/}{print,toolbox}
+               rm -f "${D}"/usr/share/applications/hplip.desktop
+               rm -f "${D}"/usr/lib/menu/hplip
+       fi
+
+       rm -rf ${D}/$(cups-config --serverbin)/filter ${D}/usr/bin/foomatic-rip
+
+       if use foomaticdb ; then
+               cd ../foomatic-db-hpijs-${DB_V}
+               emake DESTDIR="${D}" install || die "emake install failed"
+       fi
+}
+
+pkg_preinst() {
+       if use scanner; then
+               insinto /etc/sane.d
+               [ -e /etc/sane.d/dll.conf ] && cp /etc/sane.d/dll.conf .
+               [ -e ${ROOT}/etc/sane.d/dll.conf ] && cp ${ROOT}/etc/sane.d/dll.conf .
+               grep -q hpaio dll.conf || echo hpaio >> dll.conf
+               doins dll.conf
+       fi
+}