media-libs/libao: backport nanosleep() declaration
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 24 Nov 2019 11:09:50 +0000 (11:09 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 24 Nov 2019 11:10:36 +0000 (11:10 +0000)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
media-libs/libao/files/libao-1.2.2-implicit.patch [new file with mode: 0644]
media-libs/libao/libao-1.2.2-r1.ebuild [new file with mode: 0644]

diff --git a/media-libs/libao/files/libao-1.2.2-implicit.patch b/media-libs/libao/files/libao-1.2.2-implicit.patch
new file mode 100644 (file)
index 0000000..92542c8
--- /dev/null
@@ -0,0 +1,22 @@
+From 1f998f5d6d77674dad01b181811638578ad68242 Mon Sep 17 00:00:00 2001
+From: Tristan Matthews <tmatth@videolan.org>
+Date: Sun, 15 Jan 2017 12:15:07 -0500
+Subject: [PATCH] pulse: fix missing include warning for nanosleep
+
+---
+ src/plugins/pulse/ao_pulse.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/plugins/pulse/ao_pulse.c
++++ b/src/plugins/pulse/ao_pulse.c
+@@ -30,6 +30,7 @@
+ #include <assert.h>
+ #include <string.h>
+ #include <signal.h>
++#include <time.h>
+ #include <limits.h>
+ #include <pulse/pulseaudio.h>
+-- 
+2.24.0
+
diff --git a/media-libs/libao/libao-1.2.2-r1.ebuild b/media-libs/libao/libao-1.2.2-r1.ebuild
new file mode 100644 (file)
index 0000000..d03e014
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools libtool multilib multilib-minimal
+
+DESCRIPTION="The Audio Output library"
+HOMEPAGE="https://www.xiph.org/ao/"
+#SRC_URI="https://downloads.xiph.org/releases/ao/${P}.tar.gz"
+#SRC_URI="https://git.xiph.org/?p=libao.git;a=snapshot;h=refs/tags/${PV};sf=tgz -> ${P}.tar.gz"
+SRC_URI="https://github.com/xiph/libao/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="alsa nas mmap pulseaudio static-libs"
+
+RDEPEND="
+       alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+       nas? ( >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}] )
+       pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-implicit.patch
+)
+
+src_prepare() {
+       default
+       sed -i "s:/lib:/$(get_libdir):g" ao.m4 || die
+       eautoreconf
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               --disable-arts
+               --disable-esd
+               $(use_enable alsa alsa)
+               $(use_enable mmap alsa-mmap)
+               $(use_enable nas)
+               $(use_enable pulseaudio pulse)
+               $(use_enable static-libs static)
+       )
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+}
+
+multilib_src_install_all() {
+       dodoc AUTHORS CHANGES README TODO
+       find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}