dev-libs/libixion: Fix build with musl/clang
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 23 Mar 2020 00:33:20 +0000 (01:33 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 23 Mar 2020 00:33:20 +0000 (01:33 +0100)
Closes: https://bugs.gentoo.org/714018
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/libixion/files/libixion-0.15.0-musl-clang.patch [new file with mode: 0644]
dev-libs/libixion/libixion-0.15.0.ebuild

diff --git a/dev-libs/libixion/files/libixion-0.15.0-musl-clang.patch b/dev-libs/libixion/files/libixion-0.15.0-musl-clang.patch
new file mode 100644 (file)
index 0000000..be5d2e6
--- /dev/null
@@ -0,0 +1,24 @@
+From a8fe2c542b16ee30723ab3d7f3b643ee479e9723 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 23 Aug 2019 08:50:28 -0700
+Subject: [PATCH] Fix build with clang.
+
+---
+ include/ixion/model_context.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/ixion/model_context.hpp b/include/ixion/model_context.hpp
+index 6ff5b67..dc27ed0 100644
+--- a/include/ixion/model_context.hpp
++++ b/include/ixion/model_context.hpp
+@@ -61,7 +61,7 @@ public:
+         } value;
+         /** Initializes the cell to be empty. */
+-        input_cell(nullptr_t);
++        input_cell(std::nullptr_t);
+         /** Boolean cell value. */
+         input_cell(bool b);
+         /** The char array must be null-terminated. */
+-- 
+2.24.1
index 741d54be08e41ca6404845399e63261edf47c8d0..58f699f6b1955e197e56489aa311f78b7705b64d 100644 (file)
@@ -32,6 +32,8 @@ DEPEND="${RDEPEND}
        dev-libs/spdlog
 "
 
+PATCHES=( "${FILESDIR}/${P}-musl-clang.patch" ) # bug 714018
+
 pkg_setup() {
        use python && python-single-r1_pkg_setup
 }