dev-python/psutil: bump to 5.4.7
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 01:49:02 +0000 (21:49 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 02:09:55 +0000 (22:09 -0400)
* Python 3.7
* EAPI 7

Package-Manager: Portage-2.3.47, Repoman-2.3.10

dev-python/psutil/Manifest
dev-python/psutil/psutil-5.4.7.ebuild [moved from dev-python/psutil/psutil-5.4.6.ebuild with 71% similarity]

index ba6510d81d5f4f5d9fe1bd6a1236d54824ddc93b..f1ef3371738e034a449bfd23e87a9d06ffb1e7db 100644 (file)
@@ -1,3 +1,3 @@
 DIST psutil-5.4.1.tar.gz 408489 BLAKE2B 867dd9b535134ff2ef5960f774891eb4743afc5857c4e0ba7306bd4feb42f3b255a6174a092eff2814f3e2ec9d29179d23ffe495ca85dba56fc42616e67c9a8b SHA512 84d9f61cc6c51798d98ac2f727a50d85de32171645d01abf85d4f8c58bdb3b40997ab717f859de3ea21cf5b24867e1a416ee3036d6167d3fe735eca4607a110f
 DIST psutil-5.4.3.tar.gz 412550 BLAKE2B c12a8418e7a7573d23a2599c6a4df9a3aa3bbe6b9cbef9e0f48b0379944e2aa06ed498adfddc30e8d9ba8e02a08f79d4867dc1e313a62040ad3550d69d62664f SHA512 f2a0f3089c3436df52d509576795e1de14c4127918fbe63b8f116f7c097ba4d67e3b55a8da167a88c6ffd340bb443109d4887c03371810997ced4478b295f960
-DIST psutil-5.4.6.tar.gz 418059 BLAKE2B 84141bc30c4f8b9316f3dc1cd86409272af62c8b2d9269f6b4cb406ede59ba147cd7a1b78f7d176c5f98a4544a74c375699e44be36fb862219fd97d7b3efaa15 SHA512 7aefb2c1759a62fca21d1bd07f7f3aeddc368b972ce831dc6e52cda5effaee2798c6bf0aece9732dedb7fefcd8e9e3f03760d6e715be8ea1479b282150a585f3
+DIST psutil-5.4.7.tar.gz 420300 BLAKE2B e096997d22577f90cd6fc6019f2bde8855abda0eb67b496dfb8cc8dbce769e0c7da66524ac6d0c059e7a2d074a1675187af3177d904feab5a76b9b8a72c63853 SHA512 553c6de601d4c4d0c6a9dccc3eb8a449f1b3a18cd71648395ea3b43da3c92aef1565f6ce763872855d68b3de190dbd04c7f5be5ed4a79b0167d737c1825c0e2c
similarity index 71%
rename from dev-python/psutil/psutil-5.4.6.ebuild
rename to dev-python/psutil/psutil-5.4.7.ebuild
index 58d3aad83d6aca1803114173ecb21eaa8ccae96d..71eb3eb3dc9d8d724cd701d82e98ad4c8dd4a664 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
 
 inherit distutils-r1
 
@@ -18,11 +18,15 @@ IUSE="test"
 
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/mock[${PYTHON_USEDEP}] )
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/ipaddress[${PYTHON_USEDEP}]
+       )
 "
 
+# Many tests fail, even on a regular tox run on a upstream clone
 RESTRICT="test"
 
 python_test() {
-       ${PYTHON} psutil/tests/runner.py || die
+       ${PYTHON} psutil/tests/__main__.py || die
 }