gui-libs/wlroots: add patch to include EGL/eglmesaext.h
authorAaron Bauman <bman@gentoo.org>
Sun, 8 Dec 2019 18:35:42 +0000 (13:35 -0500)
committerAaron Bauman <bman@gentoo.org>
Sun, 8 Dec 2019 18:37:02 +0000 (13:37 -0500)
* Patch is currently in upstream master. Expect it to hit on next release
(0.8.2+)

Closes: https://bugs.gentoo.org/700114

Signed-off-by: Aaron Bauman <bman@gentoo.org>
gui-libs/wlroots/files/wlroots-0.8.1-eglmesaextfix.patch [new file with mode: 0644]
gui-libs/wlroots/wlroots-0.8.1-r1.ebuild

diff --git a/gui-libs/wlroots/files/wlroots-0.8.1-eglmesaextfix.patch b/gui-libs/wlroots/files/wlroots-0.8.1-eglmesaextfix.patch
new file mode 100644 (file)
index 0000000..614d0c7
--- /dev/null
@@ -0,0 +1,25 @@
+From d113e48a2a32542fe6e12f1759f07888364609bf Mon Sep 17 00:00:00 2001
+From: Ferdinand Bachmann <theferdi265@gmail.com>
+Date: Sat, 19 Oct 2019 13:33:22 +0200
+Subject: [PATCH] Add missing include required by mesa and libglvnd change
+
+eglext.h no longer inludes eglmesaext.h, include it within wlroots
+explicitly.
+
+Fixes #1862
+---
+ glgen.sh | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/glgen.sh b/glgen.sh
+index 7324fdf6b..31af28120 100755
+--- a/glgen.sh
++++ b/glgen.sh
+@@ -75,6 +75,7 @@ cat > "$OUTDIR/$BASE.h" << EOF
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+ #include <GLES2/gl2.h>
+ #include <GLES2/gl2ext.h>
index 50a4262598f9b78d54aafdbca020fb3859130f28..51f138afcfd2a90fdc1c31718828cd0b0bce91d5 100644 (file)
@@ -68,6 +68,9 @@ src_configure() {
                emesonargs+=("-Dlogind=disabled")
        fi
 
+       # Patch is currently in upstream master
+       eapply "${FILESDIR}/wlroots-0.8.1-eglmesaextfix.patch"
+
        meson_src_configure
 }