dev-libs/libtomfloat: EAPI=7 bump
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sun, 26 May 2019 08:36:32 +0000 (10:36 +0200)
committerAaron Bauman <bman@gentoo.org>
Fri, 29 Nov 2019 22:16:40 +0000 (17:16 -0500)
Closes: https://bugs.gentoo.org/686774
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12111
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-libs/libtomfloat/libtomfloat-0.02-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/libtomfloat/libtomfloat-0.02-r1.ebuild b/dev-libs/libtomfloat/libtomfloat-0.02-r1.ebuild
new file mode 100644 (file)
index 0000000..be4077c
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="library for floating point number manipulation"
+HOMEPAGE="http://www.libtom.net/"
+SRC_URI="https://github.com/libtom/libtomfloat/releases/download/${PV}/ltf-${PV}.tar.bz2"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-libs/libtommath"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       sed -i \
+               -e 's:\<ar\>:$(AR):' \
+               -e 's:\<ranlib\>:$(RANLIB):' \
+               -e "/^LIBPATH/s:/lib:/$(get_libdir):" \
+               makefile || die
+       tc-export AR CC RANLIB
+}
+
+src_install() {
+       default
+       dodoc changes.txt float.pdf WARNING
+       docinto demos ; dodoc demos/ex1.c
+}