dev-python/python-xcaplib: initial import of version 1.1.0
authorJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 00:23:33 +0000 (02:23 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 17:40:14 +0000 (19:40 +0200)
Gentoo-Bug: 446198

dev-python/python-xcaplib/Manifest [new file with mode: 0644]
dev-python/python-xcaplib/metadata.xml [new file with mode: 0644]
dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-xcaplib/Manifest b/dev-python/python-xcaplib/Manifest
new file mode 100644 (file)
index 0000000..d375d1a
--- /dev/null
@@ -0,0 +1 @@
+DIST python-xcaplib-1.1.0.tar.gz 22892 SHA256 2f8ea6fe7d005104ef1d854aa87bd8ee85ca242a70cde42f409f8e5557f864b3 SHA512 140a12e39decdd15c06816cf5969baaf82437f010592ee2f4b7309db585aaa6611ab3af50e399bb18d216ae1586b5ebf18490d74c385a99d6673171bcf437395 WHIRLPOOL 711eb094be643613a117044d2c3ea054bf728ff21a1efe668d27bebe912c67463cb15b8e0c052699f01439a6631c2570ba1e79d452cc5250383200fb2f54830b
diff --git a/dev-python/python-xcaplib/metadata.xml b/dev-python/python-xcaplib/metadata.xml
new file mode 100644 (file)
index 0000000..0dd9c15
--- /dev/null
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+       <maintainer>
+               <email>hasufell@gentoo.org</email>
+               <name>Julian Ospald</name>
+       </maintainer>
+       <longdescription lang="en">
+               XCAP protocol, defined in RFC 4825, allows a client to read, write,
+               and modify application configuration data stored in XML format on a
+               server. XCAP maps XML document sub-trees and element attributes to
+               HTTP URIs, so that these components can be directly accessed by HTTP.
+               An XCAP server used by XCAP clients to store data like presence
+               policy in combination with a SIP Presence server that supports
+               PUBLISH/SUBSCRIBE/NOTIFY SIP methods can provide a complete SIP
+               SIMPLE solution.
+
+               The XCAP client example script provided by this package can be used to
+               manage documents on an XCAP server.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild b/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..e68c80e
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_REQ_USE="ssl,xml"
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for managing XML documents on XCAP server"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/XCAP/python-xcaplib-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/python-application[${PYTHON_USEDEP}]
+"