app-crypt/acme: docs & missing indirect dep on dev-python/idna
authorRobin H. Johnson <robbat2@gentoo.org>
Sat, 20 Apr 2019 07:02:07 +0000 (00:02 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Sat, 20 Apr 2019 07:02:27 +0000 (00:02 -0700)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
app-crypt/acme/acme-0.33.1-r1.ebuild [new file with mode: 0644]
app-crypt/acme/acme-9999.ebuild
app-crypt/acme/metadata.xml

diff --git a/app-crypt/acme/acme-0.33.1-r1.ebuild b/app-crypt/acme/acme-0.33.1-r1.ebuild
new file mode 100644 (file)
index 0000000..bfa507f
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+       inherit git-r3
+       S=${WORKDIR}/${P}/${PN}
+else
+       SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+       S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="
+       >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+       >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+       >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
+       dev-python/pyrfc3339[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+       >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+       )
+       test? (
+               ${RDEPEND}
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-xdist[${PYTHON_USEDEP}]
+               dev-python/tox[${PYTHON_USEDEP}]
+       )
+       >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+"
+
+src_compile() {
+       python_foreach_impl run_in_build_dir default
+       if use doc ; then
+               cd docs || die
+               sphinx-build -b html -d _build/doctrees   . _build/html
+       fi
+}
+
+python_test() {
+       nosetests -w ${PN} || die
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+
+       distutils-r1_python_install_all
+}
index 9df5e0dbdae0c56249aebf47d76f023fee9f96c1..bfa507fa149cdcb0f68b1e30a0b8765867f9953c 100644 (file)
@@ -21,10 +21,11 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-IUSE="test"
+IUSE="doc test"
 
 RDEPEND="
-       >=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+       >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
        >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
        dev-python/mock[${PYTHON_USEDEP}]
        >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
@@ -35,14 +36,33 @@ RDEPEND="
        >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
 "
 DEPEND="
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+       )
        test? (
                ${RDEPEND}
                dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/pytest-xdist[${PYTHON_USEDEP}]
+               dev-python/tox[${PYTHON_USEDEP}]
        )
        >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
 "
 
+src_compile() {
+       python_foreach_impl run_in_build_dir default
+       if use doc ; then
+               cd docs || die
+               sphinx-build -b html -d _build/doctrees   . _build/html
+       fi
+}
+
 python_test() {
        nosetests -w ${PN} || die
 }
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+
+       distutils-r1_python_install_all
+}
index d18839cc8dacaa68cfc1f45cbb12289b674dcdba..d0f0d1620b5030775903822ab824e584f6b9c564 100644 (file)
@@ -6,6 +6,7 @@
                <name>Matthew Thode</name>
        </maintainer>
        <upstream>
+               <remote-id type="pypi">acme</remote-id>
                <remote-id type="github">letsencrypt/letsencrypt</remote-id>
        </upstream>
 </pkgmetadata>