sci-libs/vtk: fix compilation with openmpi-4
authorMatthias Maier <tamiko@gentoo.org>
Fri, 1 May 2020 14:45:17 +0000 (09:45 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Fri, 1 May 2020 16:47:27 +0000 (11:47 -0500)
Closes: https://bugs.gentoo.org/683382
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
sci-libs/vtk/files/vtk-8.1.0-openmpi-4-compatibility.patch [new file with mode: 0644]
sci-libs/vtk/vtk-8.1.0-r6.ebuild

diff --git a/sci-libs/vtk/files/vtk-8.1.0-openmpi-4-compatibility.patch b/sci-libs/vtk/files/vtk-8.1.0-openmpi-4-compatibility.patch
new file mode 100644 (file)
index 0000000..267c1d9
--- /dev/null
@@ -0,0 +1,14 @@
+diff --git a/ThirdParty/mpi4py/vtkmpi4py/src/lib-mpi/config/openmpi.h b/ThirdParty/mpi4py/vtkmpi4py/src/lib-mpi/config/openmpi.h
+index 3173831..e8ee74b 100644
+--- a/ThirdParty/mpi4py/vtkmpi4py/src/lib-mpi/config/openmpi.h
++++ b/ThirdParty/mpi4py/vtkmpi4py/src/lib-mpi/config/openmpi.h
+@@ -141,4 +141,9 @@
+ #endif
++ #if OMPI_NUMVERSION >= 40000
++ #undef  PyMPI_HAVE_MPI_LB
++ #undef  PyMPI_HAVE_MPI_UB
++ #endif /* OMPI >= 4.0.0 */
++
+ #endif /* !PyMPI_CONFIG_OPENMPI_H */
index 06e69225f0fb4d434abc37596a441f05bda99a77..9e5bc9d717cffa9fefc6f545caf743e8da94844b 100644 (file)
@@ -116,6 +116,10 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}"/VTK-${PV}
 
+PATCHES=(
+       "${FILESDIR}"/vtk-8.1.0-openmpi-4-compatibility.patch
+)
+
 RESTRICT="test"
 
 pkg_setup() {
@@ -125,6 +129,8 @@ pkg_setup() {
 }
 
 src_prepare() {
+       default
+
        local x
        # missing: VPIC freerange libproj4 mrmpi sqlite utf8 verdict xmdf2 xmdf3
        for x in constantly expat freetype hdf5 hyperlink incremental jpeg jsoncpp libharu libxml2 lz4 netcdf oggtheora png tiff Twisted txaio zlib ZopeInterface; do