dev-python/pillow: bump to 5.4.0
authorVirgil Dupras <vdupras@gentoo.org>
Wed, 2 Jan 2019 01:29:56 +0000 (20:29 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Wed, 2 Jan 2019 01:29:56 +0000 (20:29 -0500)
I had to modify SRC_URI to point to github because upstream doesn't
publish source package to pypi any more.

Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/pillow/Manifest
dev-python/pillow/pillow-5.4.0.ebuild [new file with mode: 0644]

index 550e53d9fe82c8cec38751cb989c11f929d9867d..a077bc37c9a0860c4369c6b6564be42703fa4a9a 100644 (file)
@@ -1,3 +1,4 @@
 DIST Pillow-3.4.2.zip 11042238 BLAKE2B 334af6eeadb3203b51572eca6ad9c196f3eeac14da0f1aedc351db692b33d413fdf5bc5c8564d2f53c324d9485dbdbda664b75a570b779e24f238c21829b4a39 SHA512 5e05206db5bc1b4177384f7e91ee79015c6e1bbdc7c31c997da054391b9b5ec7c1ebdec258a33f598986533894f3324b03d0b4b385b94e72a0517a3437553b39
 DIST Pillow-5.2.0.tar.gz 14499068 BLAKE2B 7111eb8e2911cc197b66bbc06a13459484e2c4a1f5037e4bcf702ea350763b2b758cbeef9749aeb29f1ab64d33081131f7e46a3fbb33fee48e70660f8f75eddb SHA512 2f19512d0573bd4696a5b4d54ff21473492f92705d33bd0994ccd085028d209bfb0031e2b95947c1e8fc9d0b0956cdf1f705c1fbaff39390791cac1708bff22c
 DIST Pillow-5.3.0.tar.gz 15553718 BLAKE2B df93d136fb5a5ea3021a757edea5dfa7b3fc1f7a71b0f64f1d1d11b95a5dafffad98d3f7b28d5e7c07b1c93d154c9c73a688f37771587c91fb7bfb6956079375 SHA512 0596207069a87a645f7694b19ea5100d753dbb7553148fa5982b073e4e1163b5bd83ddf8b1c783a90a0b718576f08d3f15352f2742d46a425cf639de2409c4ab
+DIST pillow-5.4.0.tar.gz 15717147 BLAKE2B 4bc95584532a940253b5a3f63f0688647893ee121559cb048a292857751339d7b12cae6630d7283d46e3185d7c200f6b31d9e615457b5692ca92123fbf3aa88a SHA512 e3dd704bdb04a59f07fe0c7282dbbd96b6925005c9c644825e8c96d8705b495fab4f153d40fd1108623c73163829351833ffa4fe9f4e1981b35f0b433712c436
diff --git a/dev-python/pillow/pillow-5.4.0.ebuild b/dev-python/pillow/pillow-5.4.0.ebuild
new file mode 100644 (file)
index 0000000..1bc56c0
--- /dev/null
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://python-pillow.org/"
+SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp zlib"
+
+REQUIRED_USE="test? ( jpeg tiff )"
+
+RDEPEND="
+       dev-python/olefile[${PYTHON_USEDEP}]
+       imagequant? ( media-gfx/libimagequant:0 )
+       jpeg? ( virtual/jpeg:0 )
+       jpeg2k? ( media-libs/openjpeg:2= )
+       lcms? ( media-libs/lcms:2= )
+       tiff? ( media-libs/tiff:0=[jpeg,zlib] )
+       truetype? ( media-libs/freetype:2= )
+       webp? ( media-libs/libwebp:0= )
+       zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+       )
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               media-gfx/imagemagick[png]
+       )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-5.2.0-fix-lib-paths.patch"
+)
+
+python_configure_all() {
+       # It's important that these flags are also passed during the install phase
+       # as well. Make sure of that if you change the lines below. See bug 661308.
+       mydistutilsargs=(
+               build_ext
+               --disable-platform-guessing
+               $(use_enable truetype freetype)
+               $(use_enable jpeg)
+               $(use_enable jpeg2k jpeg2000)
+               $(use_enable lcms)
+               $(use_enable tiff)
+               $(use_enable imagequant)
+               $(use_enable webp)
+               $(use_enable webp webpmux)
+               $(use_enable zlib)
+       )
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+       # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+       virtx pytest -vv -p no:relaxed
+}
+
+python_install() {
+       python_doheader src/libImaging/*.h
+       distutils-r1_python_install
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       if use examples ; then
+               docinto example
+               dodoc docs/example/*
+               docompress -x /usr/share/doc/${PF}/example
+       fi
+       distutils-r1_python_install_all
+}