closing #28015
authorDaniel Ahlberg <aliz@gentoo.org>
Mon, 13 Oct 2003 16:56:03 +0000 (16:56 +0000)
committerDaniel Ahlberg <aliz@gentoo.org>
Mon, 13 Oct 2003 16:56:03 +0000 (16:56 +0000)
net-dialup/mgetty/ChangeLog
net-dialup/mgetty/Manifest
net-dialup/mgetty/mgetty-1.1.30.ebuild

index c44decf56d3100e56956b466ecefbe509fedb847..cd47716643c6f5e723bbd913aba4e451895968fe 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for net-dialup/mgetty
 # Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.15 2003/09/07 00:33:01 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.16 2003/10/13 16:55:59 aliz Exp $
+
+  13 Oct 2003; Daniel Ahlberg <aliz@gentoo.org> mgetty-1.1.30.ebuild :
+  Install callback programs. Closes #28015.
 
   06 Sep 2003; Daniel Robbins <drobbins@gentoo.org> mgetty-1.1.30.ebuild,
   mgetty-1.1.28.ebuild: made tetex dependency conditional on "doc" USE
index 9d90af9fc102cacffdaaf7fb1b2d302804d12c18..c470d2a4db52501e4c0dc9d18cb79ad3cddac452 100644 (file)
@@ -1,7 +1,7 @@
-MD5 cfe513ae828da5d140b3743684e8da41 mgetty-1.1.30.ebuild 2633
+MD5 d4dc18714674edc148017d0990e6fe62 ChangeLog 2770
 MD5 38b8367360c7a5fd48d2b0d54d21ff0f mgetty-1.1.28.ebuild 2601
-MD5 e73a0ffc86e8dd5adde70473472ec16a ChangeLog 2658
-MD5 bc47f96a12b21b779d57c0c2ad4b6837 files/mgetty-1.1.30-gentoo.diff 2771
-MD5 a1e05459ce2d5ff673bad552f355be4f files/mgetty-1.1.28-gentoo.diff 2308
+MD5 71d2931a869071f245c33295c4d80943 mgetty-1.1.30.ebuild 3206
 MD5 504eadb9fddc097570882ddc40a66997 files/digest-mgetty-1.1.28 283
+MD5 a1e05459ce2d5ff673bad552f355be4f files/mgetty-1.1.28-gentoo.diff 2308
 MD5 c9b070dfabf7bd139d53d263f869b4f0 files/digest-mgetty-1.1.30 70
+MD5 bc47f96a12b21b779d57c0c2ad4b6837 files/mgetty-1.1.30-gentoo.diff 2771
index 5413429ebb0bf9016e101598d799d75cadaca6ed..1c69f9d118ef2d068a9ee32d685ccbd85642d584 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2003 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.30.ebuild,v 1.4 2003/09/07 00:33:01 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.30.ebuild,v 1.5 2003/10/13 16:55:59 aliz Exp $
 
 inherit flag-o-matic eutils
 
@@ -45,10 +45,20 @@ src_compile() {
                        CFLAGS="${CFLAGS}" \
                        || die
 
+       einfo "building voice"
        cd voice
        emake CONFDIR=/etc/mgetty+sendfax \
                || make CONFDIR=/etc/mgetty+sendfax \
                        || die
+
+       cd ${S}
+
+       einfo "building callback"
+       cd callback
+       emake CONFDIR=/etc/mgetty+sendfax \
+               CFLAGS="${CFLAGS}" \
+               || make CONFDIR=/etc/mgetty+sendfax \
+                       || die
        cd ${S}
 }
 
@@ -67,6 +77,22 @@ src_install () {
                spool=${D}/var/spool \
                install || die
 
+       einfo "Installing callback"
+       cd callback
+       make prefix=${D}/usr \
+               CONFDIR=${D}/etc/mgetty+sendfax \
+               MAN1DIR=${D}/usr/share/man/man1 \
+               MAN8DIR=${D}/usr/share/man/man8 \
+               VOICE_DIR=${D}/var/spool/voice \
+               SBINDIR=${D}/usr/sbin \
+               BINDIR=${D}/usr/bin \
+               INSTALL="install -c -o bin -g bin" \
+               PHONE_GROUP=root \
+               PHONE_PERMS=755 \
+               install || die
+       cd ${S}
+
+       einfo "installing voice"
        cd voice
        make prefix=${D}/usr \
                CONFDIR=${D}/etc/mgetty+sendfax \