media-sound/picard: [QA] Port to readme.gentoo-r1
authorDavid Seifert <soap@gentoo.org>
Sat, 3 Jun 2017 21:09:06 +0000 (23:09 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 3 Jun 2017 21:11:14 +0000 (23:11 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

media-sound/picard/picard-1.3.1.ebuild
media-sound/picard/picard-1.3.2-r1.ebuild
media-sound/picard/picard-1.4.1.ebuild
media-sound/picard/picard-1.4.2.ebuild

index 782c950f877f4960078b96fbed0c68853f2281db..dfa121bd47e1d91ec580af9d8db3b24c47b8c032 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 PYTHON_COMPAT=( python2_7 )
 DISTUTILS_SINGLE_IMPL=1
 DISABLE_AUTOFORMATTING=true
-inherit eutils distutils-r1 readme.gentoo
+inherit eutils distutils-r1 readme.gentoo-r1
 
 DESCRIPTION="A cross-platform music tagger"
 HOMEPAGE="http://picard.musicbrainz.org/"
@@ -26,14 +26,6 @@ RESTRICT="test" # doesn't work with ebuilds
 S=${WORKDIR}/${PN}-release-${PV}
 DOCS="AUTHORS.txt NEWS.txt"
 
-DOC_CONTENTS="If you are upgrading Picard and it does not start,
-try removing Picard's settings:
-    rm ~/.config/MusicBrainz/Picard.conf
-
-You should set the environment variable BROWSER to something like
-    firefox '%s' &
-to let python know which browser to use."
-
 src_compile() {
        distutils-r1_src_compile $(use nls || echo "--disable-locales")
 }
@@ -44,5 +36,13 @@ src_install() {
 
        doicon picard.ico
        domenu picard.desktop
+
+       local DOC_CONTENTS="If you are upgrading Picard and it does not start,
+try removing Picard's settings:
+       rm ~/.config/MusicBrainz/Picard.conf
+
+You should set the environment variable BROWSER to something like
+       firefox '%s' &
+to let python know which browser to use."
        readme.gentoo_create_doc
 }
index 2e3dfa7a9ee94f883d97c753394c53fec2540ae0..1592652f1fdd12370312f42107858d1d6a1cc652 100644 (file)
@@ -5,7 +5,7 @@ EAPI=5
 PYTHON_COMPAT=( python2_7 )
 DISTUTILS_SINGLE_IMPL=1
 DISABLE_AUTOFORMATTING=true
-inherit eutils distutils-r1 readme.gentoo
+inherit eutils distutils-r1 readme.gentoo-r1
 
 DESCRIPTION="A cross-platform music tagger"
 HOMEPAGE="http://picard.musicbrainz.org/"
@@ -27,14 +27,6 @@ RESTRICT="test" # doesn't work with ebuilds
 S=${WORKDIR}/${PN}-release-${PV}
 DOCS="AUTHORS.txt NEWS.txt"
 
-DOC_CONTENTS="If you are upgrading Picard and it does not start,
-try removing Picard's settings:
-    rm ~/.config/MusicBrainz/Picard.conf
-
-You should set the environment variable BROWSER to something like
-    firefox '%s' &
-to let python know which browser to use."
-
 src_compile() {
        distutils-r1_src_compile $(use nls || echo "--disable-locales")
 }
@@ -45,5 +37,13 @@ src_install() {
 
        doicon picard.ico
        domenu picard.desktop
+
+       local DOC_CONTENTS="If you are upgrading Picard and it does not start,
+try removing Picard's settings:
+       rm ~/.config/MusicBrainz/Picard.conf
+
+You should set the environment variable BROWSER to something like
+       firefox '%s' &
+to let python know which browser to use."
        readme.gentoo_create_doc
 }
index 16d806db46f40d210e00ba24a399f7a3219db962..763fc7e9db2141348d5e6efa294716c30491a4b6 100644 (file)
@@ -27,16 +27,6 @@ S="${WORKDIR}/${PN}-release-${PV}"
 
 DOCS=( AUTHORS.txt NEWS.txt README.md )
 
-DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
-calculation and lookup of AcoustID fingerprints.
-
-Install optional package dev-python/python-discid to enable
-calculation and lookup of compact disc identifiers (disc IDs).
-
-If you are upgrading Picard and it does not start, try removing
-Picard's settings:
-       rm ~/.config/MusicBrainz/Picard.conf"
-
 python_compile() {
        local build_args=(
                --disable-autoupdate
@@ -60,6 +50,16 @@ python_install() {
 
 python_install_all() {
        distutils-r1_python_install_all
+
+       local DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
+calculation and lookup of AcoustID fingerprints.
+
+Install optional package dev-python/python-discid to enable
+calculation and lookup of compact disc identifiers (disc IDs).
+
+If you are upgrading Picard and it does not start, try removing
+Picard's settings:
+       rm ~/.config/MusicBrainz/Picard.conf"
        readme.gentoo_create_doc
 }
 
index 16d806db46f40d210e00ba24a399f7a3219db962..763fc7e9db2141348d5e6efa294716c30491a4b6 100644 (file)
@@ -27,16 +27,6 @@ S="${WORKDIR}/${PN}-release-${PV}"
 
 DOCS=( AUTHORS.txt NEWS.txt README.md )
 
-DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
-calculation and lookup of AcoustID fingerprints.
-
-Install optional package dev-python/python-discid to enable
-calculation and lookup of compact disc identifiers (disc IDs).
-
-If you are upgrading Picard and it does not start, try removing
-Picard's settings:
-       rm ~/.config/MusicBrainz/Picard.conf"
-
 python_compile() {
        local build_args=(
                --disable-autoupdate
@@ -60,6 +50,16 @@ python_install() {
 
 python_install_all() {
        distutils-r1_python_install_all
+
+       local DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
+calculation and lookup of AcoustID fingerprints.
+
+Install optional package dev-python/python-discid to enable
+calculation and lookup of compact disc identifiers (disc IDs).
+
+If you are upgrading Picard and it does not start, try removing
+Picard's settings:
+       rm ~/.config/MusicBrainz/Picard.conf"
        readme.gentoo_create_doc
 }