dev-python/python-vitrageclient: 4.0.1 added for heat ussuri
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 16 May 2020 21:16:19 +0000 (16:16 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 16 May 2020 21:21:29 +0000 (16:21 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/python-vitrageclient/Manifest [new file with mode: 0644]
dev-python/python-vitrageclient/metadata.xml [new file with mode: 0644]
dev-python/python-vitrageclient/python-vitrageclient-4.0.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-vitrageclient/Manifest b/dev-python/python-vitrageclient/Manifest
new file mode 100644 (file)
index 0000000..2716f54
--- /dev/null
@@ -0,0 +1 @@
+DIST python-vitrageclient-4.0.1.tar.gz 47671 BLAKE2B 6e1e72d0de1cddf9f72d1ff6bdb2261f4f2295a1fdd6ebe0e9ff497b48ea545ea999d7ac7bc79adabbbdebbb3b1b36e853d083d3b6c6e9875fe44bc36f76acf4 SHA512 607d669a4ccddc0eb938c26cc4f2b2cdaac8976a7c2b774b8ce49df6bd2e5fbe4ecf210eef008d49e3d1689a686bc6e0820c3b0a11f353a2711b9b2cc743c9e1
diff --git a/dev-python/python-vitrageclient/metadata.xml b/dev-python/python-vitrageclient/metadata.xml
new file mode 100644 (file)
index 0000000..3ee7012
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-vitrageclient/python-vitrageclient-4.0.1.ebuild b/dev-python/python-vitrageclient/python-vitrageclient-4.0.1.ebuild
new file mode 100644 (file)
index 0000000..41077e0
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Vitrage API"
+HOMEPAGE="https://github.com/openstack/python-vitrageclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-3.1.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       >=dev-python/Babel-2.5.3[${PYTHON_USEDEP}]
+       >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+       !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+       >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+       >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+       >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+       >=dev-python/networkx-2.3[${PYTHON_USEDEP}]
+       >=dev-python/pydot-1.4.1[${PYTHON_USEDEP}]"