dev-vcs/subversion: fix build with >=dev-libs/libutf8proc-2.5.0
authorMike Gilbert <floppym@gentoo.org>
Thu, 7 May 2020 00:08:03 +0000 (20:08 -0400)
committerMike Gilbert <floppym@gentoo.org>
Thu, 7 May 2020 00:08:31 +0000 (20:08 -0400)
Closes: https://bugs.gentoo.org/721300
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-vcs/subversion/subversion-1.13.0-r1.ebuild

index 9534bafbacb7fced557ba4e24652b714a711c538..3cf9f17eab26af7880a7253556161f542d0e1508 100644 (file)
@@ -154,6 +154,9 @@ pkg_setup() {
 }
 
 src_prepare() {
+       # https://bugs.gentoo.org/721300
+       rm "${WORKDIR}"/patches/subversion-1.10.0_rc1-utf8proc_include.patch || die
+
        eapply "${WORKDIR}/patches"
        eapply_user
 
@@ -260,6 +263,10 @@ src_configure() {
                export ac_cv_python_compile="$(tc-getCC)"
        fi
 
+       # Remove when >=dev-libs/libutf8proc-2.5.0 is stable
+       # https://bugs.gentoo.org/721300
+       append-cppflags -I"${EPREFIX}"/usr/include/libutf8proc
+
        # allow overriding Python include directory
        ac_cv_path_RUBY=$(usex ruby "${EPREFIX}/usr/bin/ruby${RB_VER}" "none") \
        ac_cv_path_RDOC=$(usex ruby "${EPREFIX}/usr/bin/rdoc${RB_VER}" "none") \