sys-apps/debianutils: Bump to version 4.8.6.1
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 29 Jan 2019 11:12:45 +0000 (12:12 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 29 Jan 2019 11:12:45 +0000 (12:12 +0100)
Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/debianutils/Manifest
sys-apps/debianutils/debianutils-4.8.6.1.ebuild [new file with mode: 0644]

index cb07a3d14f5b0705cae376ab7a20bb2ae28bc575..6e8b1d0fe595dd4248e52bc76066197de7c79b5b 100644 (file)
@@ -1,3 +1,4 @@
 DIST debianutils_4.8.3.tar.xz 159292 BLAKE2B e655741f42594ff12b4f349331da57ec09073802c9778594619686c93fc3061cf5248ac8e9e2c1b391eb49dd572f3033b1db206ff43f373b17caf7f3c835111f SHA512 468b8f001c0338f166cbc2fe25079edc5feeaa38dce2f5c7e6724c691d6cb35f4843e987695e33ead557bb11887e78ff8a5e3e1f52a266a0f32fb978fa643897
 DIST debianutils_4.8.4.tar.xz 156344 BLAKE2B 069d15039579d4ce03d2ca4bfd0df199f0044049e7cd6ca899104eec5d917f3db290649bfdd851d8b14519df2750fb975bc6d96e98e14cdb626a610d44da80b0 SHA512 7d7b2d12d4907f6032477b4cd5b5dc94d8093724af8a97859c1d4cf229479e2dfe6d44143b454ed9b1990ca2d4833eaeb059659d8c305623875fdc8420659855
+DIST debianutils_4.8.6.1.tar.xz 156604 BLAKE2B 100bc458609273eb94da46e267395fe4ea16e499805b0d5a29f6144b8b7d2198ccb47b2048cdb6d311014c7b0ac373283cf6034a773ddbd95121856eb0dcbf83 SHA512 158f024311b3de292bd20df966c0f61285c748597101cee61e81883e0032c1e6a4baccb5c231b28f00ce3afc58a4aaedd64a65641351974c37fdb5f4952b0d2a
 DIST debianutils_4.8.6.tar.xz 156532 BLAKE2B 2add390a0e38aa3d7103e09b3b65fa2b88c3965ca411c5789409454519791bccdb12d89b1bea4d07417f733d23d0662d4f510750ab404d7a4e8f20c2bd3d7ef4 SHA512 5913729cc3c56962e8939b71803258952df0d7204df8090a7504fbefc7f5d1da8e749d606fe23148ea3294909ef172bc1f4f821690169e861729caab70921a2f
diff --git a/sys-apps/debianutils/debianutils-4.8.6.1.ebuild b/sys-apps/debianutils/debianutils-4.8.6.1.ebuild
new file mode 100644 (file)
index 0000000..3d28df9
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="https://packages.qa.debian.org/d/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="BSD GPL-2 SMAIL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
+IUSE="+installkernel static"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.2-no-bs-namespace.patch )
+
+src_configure() {
+       use static && append-ldflags -static
+       default
+}
+
+src_install() {
+       into /
+       dobin tempfile run-parts
+       if use installkernel ; then
+               dosbin installkernel
+       fi
+
+       into /usr
+       dosbin savelog
+
+       doman tempfile.1 run-parts.8 savelog.8
+       use installkernel && doman installkernel.8
+       cd debian || die
+       dodoc changelog control
+       keepdir /etc/kernel/postinst.d
+}