dev-perl/Perl-Tidy: Version bump to 20190915
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 13 Oct 2019 02:38:50 +0000 (04:38 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 13 Oct 2019 02:38:50 +0000 (04:38 +0200)
Closes: https://bugs.gentoo.org/687036
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
dev-perl/Perl-Tidy/Manifest
dev-perl/Perl-Tidy/Perl-Tidy-20190915.0.0.ebuild [new file with mode: 0644]

index ffcd6b21d6efe6b64cfd5fc909a218cfcdbee5c0..d03005baa05909c1f56fb579e6c6efd942e587e3 100644 (file)
@@ -1 +1,2 @@
 DIST Perl-Tidy-20171214.tar.gz 435256 BLAKE2B 03e7ec8e7d76e6de68a54cd474f192b24ec4eaea563dae185b1723f80ac86df7c03bafbfcdcdffc0e3a18d2b57acf3f40321637fc66a64f1d0f72988e19a7e81 SHA512 bc561146f184dd0023de44741cafdcf6882ef553ed2e0c0ec8cd9a234f45b76638b4dc7edde0abfc36e4cc1f84ef908c35dc63f776de65e2abd938d35563cc65
+DIST Perl-Tidy-20190915.tar.gz 599290 BLAKE2B b9a0b1f15e01ed6f6624c804d7833da672fd11a2779baaeb4c4d5f3d7830b2065d01d969fd23514163139bf53831fb3494d2820fe15786244e46cb0efcf722a5 SHA512 553d84bcba8cbe10c0a1e77ef9e31dfdc5957c758efa2bd556ff47a0a354f16eec922842a36c4ccdaed691ffecb6a5dad63dfee2b038f4d2c5882a7e07bad51f
diff --git a/dev-perl/Perl-Tidy/Perl-Tidy-20190915.0.0.ebuild b/dev-perl/Perl-Tidy/Perl-Tidy-20190915.0.0.ebuild
new file mode 100644 (file)
index 0000000..56aeb9a
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHANCOCK
+DIST_VERSION=20190915
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Perl script indenter and beautifier"
+HOMEPAGE="http://perltidy.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+"
+
+src_install() {
+       perl-module_src_install
+
+       # Compressing html is bad
+       docompress -x /usr/share/doc/${PF}/stylekey.html
+       docompress -x /usr/share/doc/${PF}/tutorial.html
+       docompress -x /usr/share/doc/${PF}/perltidy.html
+
+       dodoc docs/stylekey.html
+       dodoc docs/tutorial.html
+       dodoc docs/perltidy.html
+}