www-client/chromium: dev channel bump to 78.0.3887.7
authorStephan Hartmann <stha09@googlemail.com>
Thu, 22 Aug 2019 10:12:01 +0000 (12:12 +0200)
committerMike Gilbert <floppym@gentoo.org>
Thu, 22 Aug 2019 14:59:12 +0000 (10:59 -0400)
Closes: https://github.com/gentoo/gentoo/pull/12766
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
www-client/chromium/Manifest
www-client/chromium/chromium-78.0.3887.7.ebuild [moved from www-client/chromium/chromium-78.0.3880.4.ebuild with 99% similarity]
www-client/chromium/files/chromium-78-const-std-string.patch [deleted file]

index c28893eaee37ca4832bc2b33163e8ebe84eb8e29..a9c13c52880ba17182069d554dbd7581de72a0bf 100644 (file)
@@ -1,3 +1,3 @@
 DIST chromium-76.0.3809.100.tar.xz 728852892 BLAKE2B 1bd80f7fd50f82843f9367bd8d5648bcbe4b763594679cc7f57084390da840cc89d7771ffd844e3d0a3c3248d8f98a1babecabaf4c3104fa7a89efed88eae608 SHA512 63cfb45dc6bb0b1662ba4ffebc6313c24d65dae10a61752575e34a24d8d3d6f80e0422a984b560b259c299d6e493dfa177907201a1c1f785a7e294c9a03bd8a1
 DIST chromium-77.0.3865.35.tar.xz 733139780 BLAKE2B ac4040901efe6772e93dc30e371a1d63b4ea95e0a38632bcdd1aa5603674eb5696186f848916893b9138f0d1018c7b08293803afdf20e8c61e30af42c2ba26d0 SHA512 c2aa64f7153dc2992e35e8a2fa9c56fbc0684133a44e50b0986d6c423527f12cdb57f1ca503a9d4b4424003ab04eb33c270d2c4f3af6aeb23cb8506e92040f36
-DIST chromium-78.0.3880.4.tar.xz 734959036 BLAKE2B e93497cdc00c123f31b98be87c2b4c7e4e7ac18fdddf15e9c4ba6c08c89386c38f9451e432a8365cc6e1a47af244ba8d10da94acca3f108c0993f993b47a18b6 SHA512 4adf66caca7565c17571b2c9056acac3b1edbcf29ad9f8937cde241406242f4e30ac361047dddf2a60f4319245698d6872a24eae0374a142d13e3fea0c5b12ea
+DIST chromium-78.0.3887.7.tar.xz 737057024 BLAKE2B b4754f1fa9a243c29e83d6136494c6db1726a6d3f23013115a4a576428f7ca3c0fcd3f81cf7fe4037f2c3e6901b3fce015aeed7b7b945b4a3e368f2e6fb9afa1 SHA512 9b8eb33c6f19e5b247372e19a61ec1ae6c804bd7b9731222430e2e1b585146fc543a686ccfc9553d6d137999570c544cdb45696db6ce50c38dfead1b0760c1a4
similarity index 99%
rename from www-client/chromium/chromium-78.0.3880.4.ebuild
rename to www-client/chromium/chromium-78.0.3887.7.ebuild
index 82c1da7516b05388f701b3f36db28dc12881fff5..c18eb659772b8cb94e647bd270696c55a116b456 100644 (file)
@@ -148,8 +148,6 @@ PATCHES=(
        "${FILESDIR}/chromium-77-fix-gn-gen.patch"
        "${FILESDIR}/chromium-77-system-icu.patch"
        "${FILESDIR}/chromium-77-clang.patch"
-       "${FILESDIR}/chromium-77-blink-include.patch"
-       "${FILESDIR}/chromium-78-const-std-string.patch"
        "${FILESDIR}/chromium-78-include.patch"
 )
 
@@ -363,6 +361,7 @@ src_prepare() {
                third_party/widevine
                third_party/woff2
                third_party/zlib/google
+               tools/grit/third_party/six
                url/third_party/mozilla
                v8/src/third_party/siphash
                v8/src/third_party/valgrind
diff --git a/www-client/chromium/files/chromium-78-const-std-string.patch b/www-client/chromium/files/chromium-78-const-std-string.patch
deleted file mode 100644 (file)
index e16377a..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/chrome/test/chromedriver/webauthn_commands.cc b/chrome/test/chromedriver/webauthn_commands.cc
-index b0d4d62..6369d74 100644
---- a/chrome/test/chromedriver/webauthn_commands.cc
-+++ b/chrome/test/chromedriver/webauthn_commands.cc
-@@ -36,8 +36,8 @@ base::DictionaryValue MapParams(
- // Converts the string |keys| in |params| from base64url to base64. Returns a
- // status error if conversion of one of the keys failed.
- Status ConvertBase64UrlToBase64(base::Value* params,
--                                const std::vector<const std::string> keys) {
--  for (const std::string key : keys) {
-+                                const std::vector<std::string> keys) {
-+  for (std::string key : keys) {
-     base::Value* maybe_value = params->FindKey(key);
-     if (!maybe_value)
-       continue;
-@@ -60,8 +60,8 @@ Status ConvertBase64UrlToBase64(base::Value* params,
- // Converts the string |keys| in |params| from base64 to base64url.
- void ConvertBase64ToBase64Url(base::Value* params,
--                              const std::vector<const std::string> keys) {
--  for (const std::string key : keys) {
-+                              const std::vector<std::string> keys) {
-+  for (std::string key : keys) {
-     std::string* maybe_value = params->FindStringKey(key);
-     if (!maybe_value)
-       continue;