dev-python/jmespath: add python3_7, EAPI=7
authorAndrey Utkin <andrey_utkin@gentoo.org>
Sat, 8 Sep 2018 23:59:54 +0000 (00:59 +0100)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Wed, 19 Sep 2018 00:03:47 +0000 (01:03 +0100)
Acked-by: Alexis Ballier <aballier@gentoo.org>
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-python/jmespath/jmespath-0.9.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/jmespath/jmespath-0.9.3-r1.ebuild b/dev-python/jmespath/jmespath-0.9.3-r1.ebuild
new file mode 100644 (file)
index 0000000..252f4e7
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON Matching Expressions"
+HOMEPAGE="https://github.com/boto/jmespath https://pypi.org/project/jmespath/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+       nosetests || die
+}