dev-perl/self: Add build fix for Perl 5.26, bug 623118
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 3 Jul 2017 21:26:17 +0000 (23:26 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 3 Jul 2017 21:26:17 +0000 (23:26 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/self/self-0.350.0.ebuild

index d37cdb87b59801adf6e70a5b02b118440398bbfe..50660fedf448806d2b8d4980caf6fc33ce47331f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -25,3 +25,9 @@ DEPEND="${RDEPEND}
        >=virtual/perl-ExtUtils-MakeMaker-6.590.0
        test? ( >=virtual/perl-Test-Simple-0.420.0 )
 "
+
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}