dev-python/protobuf-python: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 12:38:13 +0000 (13:38 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 12:42:16 +0000 (13:42 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/protobuf-python/Manifest
dev-python/protobuf-python/protobuf-python-3.10.1.ebuild [deleted file]
dev-python/protobuf-python/protobuf-python-3.11.2.ebuild [deleted file]

index 2ec932522c73efd059b11a0cd745648928186a8c..81632cac52b016f49f019f18611595ef59a0d212 100644 (file)
@@ -1,3 +1 @@
-DIST protobuf-3.10.1.tar.gz 4905995 BLAKE2B 1dde3b6260918da8430c2ce69210462f339c492b2a4e53d5d9c1bea3747aead905370507fc4bd703560f6885c0f3f8393a998b875c19744ad94827109ecbb49f SHA512 aba0c4034c0d3b1759904adb6270eee94dd5dc568f433b219e3f1f70c0033993cdfa3bf476ad3f5767c7629edb9fd029c686405abf93731dde808286b336330d
-DIST protobuf-3.11.2.tar.gz 5133897 BLAKE2B 275ea52a072b4e0226e4b6dc476d4bc28e8f4f05bca0709eab51da91c02869e96c3b0ac9ab4cc46290f875d4eac6ac72374c5b45e27fa89ad3d58fd56a2c8b7e SHA512 8319c1e003e5fc64e91b512de016ec1cf10265b294d3b4beea60856beaeb02b4d7682343c74b2c12b0f6d4d6258451af9b9d72bcb4b495293b7637da21030c8f
 DIST protobuf-3.11.4.tar.gz 5140799 BLAKE2B 97b450c0623593efe6a42b66582ff183344b8831689e6a5b4d36096dbd57c33da9569bbf26578536aaf73ecd866ac0588b6cb7d55a6a9b9a6e840d4c57099001 SHA512 777bbb0e9e2375eaebe6b8c87abd660bac70ee469c9ad00dd25917b82d7fb5bbe33cf87f0d69c90e19d55c07a7285ec20974ba4768623ce9ccfadf147fd5e261
diff --git a/dev-python/protobuf-python/protobuf-python-3.10.1.ebuild b/dev-python/protobuf-python/protobuf-python-3.10.1.ebuild
deleted file mode 100644 (file)
index cd9cf69..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 2008-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_6,3_7,3_8})
-DISTUTILS_USE_SETUPTOOLS="manual"
-
-inherit distutils-r1
-
-if [[ "${PV}" == "9999" ]]; then
-       inherit git-r3
-
-       EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf"
-       EGIT_SUBMODULES=()
-fi
-
-DESCRIPTION="Google's Protocol Buffers - Python bindings"
-HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/protocolbuffers/protobuf"
-if [[ "${PV}" == "9999" ]]; then
-       SRC_URI=""
-else
-       SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
-fi
-
-LICENSE="BSD"
-SLOT="0/21"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-
-BDEPEND="${PYTHON_DEPS}
-       ~dev-libs/protobuf-${PV}
-       dev-python/namespace-google[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${PYTHON_DEPS}
-       ~dev-libs/protobuf-${PV}"
-RDEPEND="${BDEPEND}
-       !<dev-libs/protobuf-3[python(-)]"
-
-S="${WORKDIR}/protobuf-${PV}/python"
-
-if [[ "${PV}" == "9999" ]]; then
-       EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
-fi
-
-python_configure_all() {
-       mydistutilsargs=(--cpp_implementation)
-}
-
-python_compile() {
-       python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
-       distutils-r1_python_compile
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       find "${D}" -name "*.pth" -type f -delete || die
-}
diff --git a/dev-python/protobuf-python/protobuf-python-3.11.2.ebuild b/dev-python/protobuf-python/protobuf-python-3.11.2.ebuild
deleted file mode 100644 (file)
index c50c48f..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 2008-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_6,3_7,3_8})
-DISTUTILS_USE_SETUPTOOLS="manual"
-
-inherit distutils-r1
-
-if [[ "${PV}" == "9999" ]]; then
-       inherit git-r3
-
-       EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf"
-       EGIT_SUBMODULES=()
-fi
-
-DESCRIPTION="Google's Protocol Buffers - Python bindings"
-HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/protocolbuffers/protobuf"
-if [[ "${PV}" == "9999" ]]; then
-       SRC_URI=""
-else
-       SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
-fi
-
-LICENSE="BSD"
-SLOT="0/22"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-
-BDEPEND="${PYTHON_DEPS}
-       ~dev-libs/protobuf-${PV}
-       dev-python/namespace-google[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${PYTHON_DEPS}
-       ~dev-libs/protobuf-${PV}"
-RDEPEND="${BDEPEND}
-       !<dev-libs/protobuf-3[python(-)]"
-
-S="${WORKDIR}/protobuf-${PV}/python"
-
-if [[ "${PV}" == "9999" ]]; then
-       EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
-fi
-
-python_configure_all() {
-       mydistutilsargs=(--cpp_implementation)
-}
-
-python_compile() {
-       python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
-       distutils-r1_python_compile
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       find "${D}" -name "*.pth" -type f -delete || die
-}