app-emacs/helm: Version bump to 3.6.0.
authorUlrich Müller <ulm@gentoo.org>
Mon, 16 Dec 2019 19:30:39 +0000 (20:30 +0100)
committerUlrich Müller <ulm@gentoo.org>
Mon, 16 Dec 2019 20:14:52 +0000 (21:14 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/helm/Manifest
app-emacs/helm/helm-3.6.0.ebuild [new file with mode: 0644]

index c4d109907e657cfa13ea685d464c3964588122e8..a9d7bbb9a011fd9d663cb4ac0664873890598f19 100644 (file)
@@ -1 +1,2 @@
 DIST helm-3.2.tar.gz 2285972 BLAKE2B b5385b805825d89ed87ba438ce830ce1e694cf842db590576b0ceaa2c110f5d0853b24211fdeebb77394c5ecca8460bcd52fe58240233ea10993504030328e9e SHA512 006e53f1984d38fa6305830179bc4ef04fa3007effa07685ddf479c1fbca547b6f8e99dd370f5653d57b2f8e519a54948a4730a0fdf9af8574cbfa27c09662d5
+DIST helm-3.6.0.tar.gz 2302677 BLAKE2B e9a83a1a4f46c1256090ff458ffc3cb158aaa320a067fb1474c9f62bd0cceaf98c53191790113c8af228d8a47fc7d2585a528ffed3e6e06030a4308f9c65e095 SHA512 1cfaf5cdef9203bb92b80c684b21ec7ca92df00aa2e82815e8f39c623648232405273fb272244d7d2b2756f4699f82f93e9a669a13a71da9410f0c0f9df30393
diff --git a/app-emacs/helm/helm-3.6.0.ebuild b/app-emacs/helm/helm-3.6.0.ebuild
new file mode 100644 (file)
index 0000000..f852381
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/async
+       app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+       elisp-compile *.el
+       elisp-make-autoload-file
+}
+
+src_install() {
+       elisp_src_install
+       exeinto "${SITEETC}/${PN}"
+       doexe emacs-helm.sh
+}