net-im/bitlbee: use acct-{group,user}/bitlbee
authorPetr Vaněk <arkamar@atlas.cz>
Mon, 10 Feb 2020 22:49:31 +0000 (23:49 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 5 May 2020 08:46:34 +0000 (11:46 +0300)
Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-im/bitlbee/bitlbee-3.5.1.ebuild
net-im/bitlbee/bitlbee-3.6.ebuild
net-im/bitlbee/bitlbee-9999.ebuild

index 3ce9cca1ef238b2c7983bd859d258d468f52fb9e..4d724abf2b81a0f3e7a9919c6379831c574099bd 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-inherit user systemd toolchain-funcs
+inherit systemd toolchain-funcs
 
 if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -30,6 +30,8 @@ REQUIRED_USE="
 "
 
 COMMON_DEPEND="
+       acct-group/bitlbee
+       acct-user/bitlbee
        >=dev-libs/glib-2.16
        purple? ( net-im/pidgin )
        libevent? ( dev-libs/libevent:= )
@@ -52,11 +54,6 @@ RDEPEND="${COMMON_DEPEND}
        virtual/logger
        xinetd? ( sys-apps/xinetd )"
 
-pkg_setup() {
-       enewgroup bitlbee
-       enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
 src_prepare() {
        if [[ ${PV} != "9999" ]]; then
                eapply \
index 9df170295b6b04fb3e410b85082b058e9d5b5670..6643e1c5920cbc9a3805d143882768815b480dd7 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit user systemd toolchain-funcs
+inherit systemd toolchain-funcs
 
 if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -30,6 +30,8 @@ REQUIRED_USE="
 "
 
 COMMON_DEPEND="
+       acct-group/bitlbee
+       acct-user/bitlbee
        >=dev-libs/glib-2.16
        purple? ( net-im/pidgin )
        libevent? ( dev-libs/libevent:= )
@@ -51,11 +53,6 @@ DEPEND="${COMMON_DEPEND}
 RDEPEND="${COMMON_DEPEND}
        xinetd? ( sys-apps/xinetd )"
 
-pkg_setup() {
-       enewgroup bitlbee
-       enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
 src_prepare() {
        [[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${PN}-3.5-systemd-user.patch
        eapply_user
index 9df170295b6b04fb3e410b85082b058e9d5b5670..6643e1c5920cbc9a3805d143882768815b480dd7 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit user systemd toolchain-funcs
+inherit systemd toolchain-funcs
 
 if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -30,6 +30,8 @@ REQUIRED_USE="
 "
 
 COMMON_DEPEND="
+       acct-group/bitlbee
+       acct-user/bitlbee
        >=dev-libs/glib-2.16
        purple? ( net-im/pidgin )
        libevent? ( dev-libs/libevent:= )
@@ -51,11 +53,6 @@ DEPEND="${COMMON_DEPEND}
 RDEPEND="${COMMON_DEPEND}
        xinetd? ( sys-apps/xinetd )"
 
-pkg_setup() {
-       enewgroup bitlbee
-       enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
 src_prepare() {
        [[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${PN}-3.5-systemd-user.patch
        eapply_user