media-libs/libpgf: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:00 +0000 (18:31 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:00 +0000 (18:31 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/libpgf/libpgf-6.12.27.ebuild

index 4e0807e33311dc550127f4811ad5e1228bbfb656..1f8156146d8db0144c0a3308758ba11410184690 100644 (file)
@@ -1,7 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
+
 inherit autotools
 
 DESCRIPTION="Library to load, handle and manipulate images in the PGF format"
@@ -11,13 +12,15 @@ SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.bz2"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="amd64 ~ppc x86"
-IUSE="doc static-libs"
+IUSE="doc"
 
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )
-       app-arch/unzip"
+BDEPEND="
+       app-arch/unzip
+       doc? ( app-doc/doxygen )"
 
 src_prepare() {
+       default
+
        if ! use doc; then
                sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am || die
        fi
@@ -26,11 +29,12 @@ src_prepare() {
 }
 
 src_configure() {
-       econf $(use_enable static-libs static)
+       econf --disable-static
 }
 
 src_install() {
        default
 
-       find "${ED}" -name '*.la' -delete || die
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }