dev-python/pytest-localserver: Provide a pure py3 revision
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 08:49:32 +0000 (10:49 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 10:16:59 +0000 (12:16 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-localserver/pytest-localserver-0.5.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pytest-localserver/pytest-localserver-0.5.0-r1.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.5.0-r1.ebuild
new file mode 100644 (file)
index 0000000..bdee104
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Py.test plugin to test server connections locally"
+HOMEPAGE="https://pypi.org/project/pytest-localserver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+
+RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? (
+               ${RDEPEND}
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/requests[${PYTHON_USEDEP}]
+               dev-python/six[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest