dev-python/h5py: bump to 2.9.0.
authorBenda Xu <heroxbd@gentoo.org>
Sun, 27 Jan 2019 11:01:26 +0000 (19:01 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Sun, 27 Jan 2019 11:01:50 +0000 (19:01 +0800)
Suggested-By: Erik Quaeghebeur, Peter Große
Closes: https://bugs.gentoo.org/672148
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
dev-python/h5py/Manifest
dev-python/h5py/h5py-2.9.0.ebuild [new file with mode: 0644]

index 4a6a12e9117f0faaa822304ae53b54361692f7b5..c360c86ed4f2ff307e2d6eff12712f303a613cfb 100644 (file)
@@ -1,2 +1,3 @@
 DIST h5py-2.7.0.tar.gz 256471 BLAKE2B c232eb86d00b9d1bb76903ea04bfd384bae7c9eb7b301de6aa450a46918f69132ab8d8d5a3f9b54095feee436a8aa9e9045c27ca1a120d665d6031c14218f0f5 SHA512 7c1e5d8b47c176521f5f62cfc4f782c09a0e003c5cbc07a673ccc3dfbe97df930b33801ef7311360892e3fad1d7d72561a8578aed9cb630d44e1a73543bb5da4
 DIST h5py-2.7.1.tar.gz 264225 BLAKE2B ffb0b52127f6cb9634b5ac3266a36bc0003144d302bdc300fff5f6f33e52b5a12e954cc2ef9fdfe9dfa0eddc810b30ee3f556cab2a31338500db666b87e64ddc SHA512 b702e3875c2767d2fabe66601820c517671fb5fc3321334aba081950b625435a1262554f39187cd1b41c6069e2b3826db6f0b610bfed2abe5db8a4dd8a29ecfd
+DIST h5py-2.9.0.tar.gz 287853 BLAKE2B f1e5c985ec1431dca2b14490711ec7f125620e67ee6cecb56306d19cc8fd1d1c33d313f6477e98c4dbb780cc50c3a4ca073cfe69e079187f8f52a301aab60467 SHA512 73b1f59e3e2b3eceebf7b97e49bd8f5199afafd7ef29917af05ff8415c2f2129a5c59db9658944370c9bcf8fc04ab26948ee27fc6fd948a22d19cace1ce8c853
diff --git a/dev-python/h5py/h5py-2.9.0.ebuild b/dev-python/h5py/h5py-2.9.0.ebuild
new file mode 100644 (file)
index 0000000..9ffc566
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="http://www.h5py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test examples mpi"
+
+RDEPEND="
+       sci-libs/hdf5:=[mpi=,hl(+)]
+       dev-python/numpy[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+       ${RDEPEND}
+       dev-python/cython[${PYTHON_USEDEP}]
+       dev-python/pkgconfig[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/alabaster[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
+               )
+       mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+       use mpi && export CC=mpicc
+}
+
+python_prepare_all() {
+       append-cflags -fno-strict-aliasing
+       distutils-r1_python_prepare_all
+}
+
+python_configure() {
+       esetup.py configure $(usex mpi --mpi '')
+}
+
+python_compile_all() {
+       if use doc; then
+               cd "${S}"/docs || die
+               sed '/html_theme/s:default:alabaster:g' -i conf.py || die
+               emake html
+       fi
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       DOCS=( README.rst ANN.rst )
+       use doc && HTML_DOCS=( docs/_build/html/. )
+       use examples && DOCS+=( examples )
+
+       distutils-r1_python_install_all
+}